• Rev2 aka, "What do you mean RX doesn't go to RX and TX doesn't go to TX?"

    morgan11/15/2018 at 22:19 3 comments

    I don't know how many times I've done it. But I'm sure I'll do it again. Some dyslexic holdover from childhood where I cannot get it straight.

    TX connects to RX. RX connects to TX.

    Okay! Schematic is updated, besides the obvious fixing TX/RX I also decided to ditch the test pads. As much as I'd like to be making test jigs I just don't have time. So instead I added a 12 pin header and broke out a bunch of important signals.

    • TX
    • RX
    • GND
    • 3v3
    • EN
    • GPIO0
    • DTR
    • RTS
    • GPIO4

    The top is pretty clean; UART, Power, Reset, Bootload

    The last 4 are the GPIOs for the LEDs, I'm questioning if I need DTR/RTS. Maybe the button is more useful...

    Anyhow. Another update on the layout coming shortly.

  • Added schematic

    morgan03/30/2018 at 00:22 0 comments

    PDF in Files section. Bring on opinions, critiques, ridicule  or advice.

  • Twelve hours with the yak in the corner.

    morgan03/24/2018 at 09:45 2 comments

    My hackerspace, Sudo Room, has a pick and place machine. I'm not sure anyone asked for it, or suggested we needed it, but there it is, and I love it.

    My opinion on it's overall usefulness is still out but I do know without regular use and changing out parts a batch of common parts to design against cannot be established. Today I had 8 unique parts placed in 24 positions and for the most part it went pretty well. I wrote a script, pos2charmhigh to convert KiCAD Footprint Position File (.pos) to the awkward CSV that this lovely machine understands. For the most part it gets the job done but this is the first project that has two part of the same value with different footprints and well... yeah, that's a thing it doesn't handle. That's enough on the PNP.

    Laser Paste

    In the past I've used some fancy solder paste and our janky, err, lovely IR reflow over but was never really happy with the results even with dead simple boards. This time I tried QuickChip Sn42/Bi58 (Tin/Bismuth) low temp solder past on a hotplate and skillet. As I love playing with bismuth so that's an easy win for me.

    After cutting a stencil in Mylar I applied the paste as normal* using a card as a squeegee. This worked for most of the parts, the biggest exception being the LGA-14 package. The laser had no chance of cutting holes that small, it barely managed the QFN parts.

    * Normal application of solder paste involves several attempts, foul language and a huge mess.

    Home Fried Circuits

    After several less that successful attempts with the reflow oven I decided to go with the hot plate and hot air technique, though in the initial pass I didn't even use hot air. It was supposed to melt at 138C but didn't actually until right before 150C, which is totally manageable. All in all, happy with the results.

    Baffling Part Selection

    For some reason, that is beyond me,know solely by Morgan from several weeks ago, I ended up with a SOT89-3 footprint on my board. What is this footprint? Iuhuh. Who even uses this footprint? Iuhuh. Why did we use it then? Iuhuh. So, not only is this part simply unavailable, I completely missed it when ordering parts and ordered the AP2127 is SOT-23-5 like a sensible human being. Not that noticing would have matter as boards were out already. But with some creative squinting and lead removal I managed to get that SOT-23 on that, guess the footprint is fine?

    Beyond baffling (so baffling) mistake there's a lot going on with the battery switching circuit so I just pull the P-Channel MOSFET for now, I can get that working once this thing boots.

    Smoke and Impatience

    There was some smoke, a CP2102 went before its time. Bah.

    After the tears were wiped away and I took my time to check and clean bridges some problems started popping up. I used TSV protection diodes in a 6SON package but hasn't extended the pads outside the housing, I think this may have had a short underneath. I just took it out as I couldn't really verify what was going on under there. I replaced the CP2102 and generally hit everything with hot air and rechecked for bridges.

    Boot! Boot? Bah!

    Wrapping up....

    I can see the CP2102 when I plug USB in, that's a good sign. But esptool fails to communicate with the PICO. This could be a power issue still, or something with the reset circuit, I don't know. This will be a problem for sometime in the future Morgan. I wish him luck.