Close
0%
0%

WiFi Webradio with ESP8266 and VS1053

A wifi web radio player with only low costs boards.
KaRadio, listen the world.

Similar projects worth following
Control with any browsers (ie edge, chrome mozilla etc...).
or with an external hardware panel or with the uart interface.
Memory for 255 stations
OTA upgrade
Read direct mp3 or ogg streams or playlist .pls .m3u and .xspf
Read up to a 320 kb/s stream,
Embedded wifi configuration via the web or uart interface
Metadata displayed (ie Title of the current song if given in the stream),
All settings saved (sound setting, stations, wifi)
Server multi clients with automatic refresh for all (websocket),
The stations can be downloaded and uploaded within the web site,
Stations sort management by drag drop.
very quick responsive web by caching local information in the browser and websocket.
additional hardware: a led indicates the state of the equipment (gpo2->resistor->led->3.3volt). Speed blink: init, 90%in 10%out: connection in progress, 10% in 90%out: Equipment ready.
Optional: control switches, lcd display., additional ram for buffering.

See http://www.instructables.com/id/Wifi-Webradio-With-ESP8266-and-VS1053 for the description of the minimal prototype.

See Github for sources

See the lcd +IR software's on Github AddOn

See some realizations of users at KaraDio

A nice telnet+IR extension from Gábriel Kovács gabeszakem@gmail.com: ESP8266-WiFi-UART-Bridge-master.zip

A nextion touchscreen display for KaraDio from yo2ldk : Here

For more informations or questions, you can enter to the Karadio facebook group


Release 1.2.2

New features:

  • Volume correction for the control panel.
  • The volume is now saved every second if needed (less stress for the flash).
  • Stability

Built on 2017/05/22

Older releases:

- New uart command: sys.date Send a ntp request and Display the current locale time
- New uart command: sys.tzo Display or change the timezone offset
See Interface.txt-

New No needs to parse the url of stations on the web interface. Now it can be done automatically.

- New uart command: cli.info Display nameSet, all icy and volume. Used to synchronize the lcd extension.
- cli.list command modified.

- Now Both AP SSID and AP Password are encoded to permit special characters like & : etc
- "Restore stations" corrected for some heavy lists
- Station information now give the number of the current station
- retry client connection modified to avoid blocking situation.

- Modification of the list of uart command. See uart and html interfaces
- New sys.patch command. Inhibit or permit (default) the load of a vs1053 patch for AAC stations.
- New sys.led command. Default is blinking mode, or Play mode: the led is on when a station is playing.
- Modification of the wifi.con command. Now the AP can be set in the AP
mode (192.168.4.1) without the need of the web interface.
- New print button on the Stations panel: Print the list of stations, number and name.
- New logo ;-)
- Many bugs removed thanks to users feedback's.
- Modification of the list of uart command. See uart and html interfaces
- New IR and LCD software
- Autoplay corrected

- Now 2 AP's can be set. The second one will be tested if the first is not detected.
- The Mac address of the radio is displayed
- An offset volume can be set for each station in Station editor.
- Added: a reset button for the equalizer
- Pb on Autostart not correctly checked: corrected
- New html command: instant="http://your url"
- The path of a station can now include some & parameters.
-- Uart command list now can take a parameter: the number of the station to display.
.If no parameter, the complete list is sent.
- New wake and sleep features. Two modes: Time mode: "hh:mm" to wake or sleep at a given hour, or the delay mode "mm".
- Many minors html adjustments.
- The user agent for http request can be set for some special streams.Example: http://pcradio.ru/player/listradio/pcradio_ru.xml
which need a user agent= pcradio.
This pcradio user agent is already implemented automatically in the code when a pcradio station is encountered.
- Drag an drop on the stations list: rearrange the list by dragging a line to another one. Save the change when asked.
- Themes toggle between light blue and dark marron theme with a click on the logo.
- Sleep mode to stop the play after a delay.
- Functions on the web page are optimized.
- Many minor improvements on the code and the web page.
- New uart interface command: cli.uart("x")
With x the uart baudrate at the next reset and permanently.
List of valid baudrate: 1200, 2400, 4800, 9600, 14400, 19200, 28800, 38400, 57600, 76880, 115200, 230400
The command will reply with
##CLI.UART= 115200# on the next reset.
- New Station selection with number
- Stations management in one page
- abort button on station edition.
- New html interface. Can receive basic commands (play, stop, volume from wget or browser)
- New I2S external DAC interface on the vs1053. The I2S is enabled by default to 48kHz. To change the speed permanently use the uart interface with the command :
cli.i2s("x") with x =0 for 48kHz, x=1 for 96kHz and x=2 for 192kHz
The i2s...

Read more »

octet-stream - 392.50 kB - 05/22/2017 at 16:03

Download

octet-stream - 392.50 kB - 05/22/2017 at 16:03

Download

boot_v1.6.bin

A new one. Don't know what is new.

octet-stream - 3.77 kB - 01/10/2017 at 11:04

Download

octet-stream - 4.00 kB - 07/21/2016 at 15:19

Download

esp_init_data_default.bin

Must be written only one time.

octet-stream - 128.00 bytes - 07/21/2016 at 15:18

Download

View all 6 files

View all 6 components

View all 10 project logs

  • 1

    Wiring:

    From ESP8266_ESP12( 3.3 v) or nodeMCU(5v) to VS1053 (5 v)

    REST:

    ADC : gound if control panel not used

    CH_PD to 3.3v

    GPIO16 led output

    D5:GPIO14 to VS1053 SCK

    D6:GPIO12 to VS1053 MISO (or so)

    D7:GPIO13 to VS1053 MOSI (or si)

    TXD to CH340G UART rx

    RXD from CH340G UART tx

    D1:GPIO05 to VS1053 XDCS

    D2:GPIO04 to VS1053 DREQ

    D3:GPIO00 to VS1053 XRST

    GPIO02

    D8:GPIO15 to VS1053 XCS

  • 2

View all instructions

Enjoy this project?

Share

Discussions

brony wrote 05/20/2017 at 04:53 point

Hi. Could you implement so called "radio buttons" to select preset stations?

  Are you sure? yes | no

aqvarius-sey wrote 05/18/2017 at 14:57 point

on version 1.1.5 strange problem. if you have installed memory and increase the volume of the radio goes silent. only a reboot helps. if the memory is to retrieve all works. checked all the connection is correct.

  Are you sure? yes | no

aqvarius-sey wrote 05/18/2017 at 10:05 point

hi! in the beginning I want to say thank you for a great project! I have a question to the Creator. updated from version 1.1.5 to 1.2.1. buttons connected to an analog input. problems: 1. when adjusting the volume there is no smooth adjustment while holding the button. 2. when you press short the volume randomly changes (jumps from low to high and back). in version 1.1.5 often, she cleared the EEPROM in the esp8266, you need to re-set the network settings, and list of stations.

  Are you sure? yes | no

AndrzejSc wrote 05/16/2017 at 14:32 point

I have a problem when change uart to 9600, after reset radio doesn't play. If I change back to 115200 it's play again. Debug informations is the same at both cases. Any ideas ?

  Are you sure? yes | no

ldv82 wrote 05/16/2017 at 09:44 point
What are the advantages of ESP32? Any new functions will be at the radio?

  Are you sure? yes | no

jp cocatrix wrote 05/16/2017 at 09:53 point

Don't know yet ;-)
Just for fun and may be bluetooth, but I have to learn it before.

  Are you sure? yes | no

ldv82 wrote 05/15/2017 at 13:54 point

jp cocatrix 

Do not plan a version STM32+SSD1306+encoder?

  Are you sure? yes | no

jp cocatrix wrote 05/15/2017 at 22:32 point

Yes, i'am working on it. Some technical problem with u8glib ...

  Are you sure? yes | no

Roman wrote 05/13/2017 at 15:29 point

HI,Problem! Radio sometimes stops working (hangs)!!!!

Thanks

Best regards,
~~ Roman

  Are you sure? yes | no

Flex wrote 05/14/2017 at 15:04 point

Hey,

I’ve got a similar problem, sometimes stops the VS Coding and needs a reset. The NodeMCU and Website keep working well, but the speaker didn’t get a signal from the decoder. It seems to happen randomly, sometimes after 20min and othertimes the systems run over hours perfectly.


I use an NodeMCU connected to an Arduino (for the OLED and a FM transmitter), buttons and such an VS1053: http://www.ebay.de/itm/VS1053-MP3-Module-Development-Board-w-On-Board-Recording-Function-SPI-Interface-/291596880495?hash=item43e4874a6f:g:gm4AAOSwEK9Tw2qE

It could be a pointer issue of the VS, when I stream from my Shoutcast-Server with 320kbps stereo it feels like the problem comes earlier as if I stream with 98kbps mono signal.

Greets

Felix

  Are you sure? yes | no

cwojtala wrote 05/03/2017 at 11:49 point

Hi, i've got an issue. I flashed the esp8266 with the esptool like this:

esptool.py write_flash 0x000 boot_v1.6.bin 0x01000 user1.4096.new.4.bin
0x81000 user2.4096.new.4.bin 0x7e000 blank.bin 0x3fe000 blank.bin
0xfc000 esp_init_data_default.bin 0x3fc000 esp_init_data_default.bin

and it seemed to work. i can connect to the AP but when i fill in the SSID ans password an then click validate nothing happens, after a reset its still in ap mode....

pls hlp

chris

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 13:46 point

dhcp, or ip,mask,  gateway?

In dhcp the ip may be read on the uart interface.

  Are you sure? yes | no

cwojtala wrote 05/03/2017 at 13:59 point

i.ve tried both. it starts always in ap mode again

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 14:01 point

check with a terminal on the usb com port. You will see the error. Certainly a bad password.

  Are you sure? yes | no

cwojtala wrote 05/03/2017 at 14:51 point

dont ask m how but after a couple resets ist working now. what i observed is tha at the beginning there was no mac adress next to the wlan security options, but now is is there and its working. thx for this very cool project

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 14:23 point

notice that the validate will reset automatically. It is the validate on right of the Wifi & Network label

  Are you sure? yes | no

Vishal Dhayalan wrote 04/22/2017 at 22:51 point

Hi again, can you also tell me which files i need to flash onto the ESP8266 NodeMCU and any other details required in this process? There seems to be more files in the 'files' section, than shown in the images on instructables for this project... Thank you.

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 13:50 point

Which one?

  Are you sure? yes | no

Vishal Dhayalan wrote 04/22/2017 at 22:48 point

Hi, is it possible to add IR-Remote alone, without a display? and i would like it to just run on the esp8266 NodeMCU, without an arduino, as I'm trying to run on a minimum setup with basic user controls. Love all the effort and time you've put into this! Thank you.

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 13:48 point

no, not without arduino mini pro. But you can have IR remote without display. Just don't add it.

Thanks

  Are you sure? yes | no

Paul wrote 04/14/2017 at 01:41 point

Hi, the ntp client is a fantastic new feature, for some reason the time is returning as UTC +1. When I add my tzo ("+8") the clock reads one hour ahead. I have changed my tzo to +7 to give me the correct time for now. Will you be correcting this in the future. We don't have dst where I live, so thats not the issue.

Thanks for all your hard work on this project :) 

  Are you sure? yes | no

jp cocatrix wrote 05/03/2017 at 13:52 point

No, it is a simplified implementation.

  Are you sure? yes | no

cwojtala wrote 04/09/2017 at 12:12 point

I'm a little  bit confusedFirst: if i connect the buttons to the adc, do i have to change the firmware in the esp8266?

And second: i've odered this Module: 

VS1003B VS1053 MP3 Module Development Board Onboard recording function

 http://s.aliexpress.com/veUV3iiU 
(from AliExpress Android)

Does ist work with ist? If yes, how do i connect it to the ESP Board?

  Are you sure? yes | no

jp cocatrix wrote 04/09/2017 at 12:43 point

1/ No, it is auto detected in software.

2/ Not sure, it is a vs1003. Partial support only by Karadio. Some doesn't work at all.
Th wire is well noted on the board. Same as vs1053.

  Are you sure? yes | no

cwojtala wrote 04/10/2017 at 11:48 point

thanks. Knowing my luck, my board won't work. But i can tell when it arrive from china

  Are you sure? yes | no

Eugene wrote 04/18/2017 at 16:13 point

This board works correctly with this project, have the same one

  Are you sure? yes | no

fjs1 wrote 04/04/2017 at 12:47 point

A really fantastic piece of work !  It works better than all IP radios (commercial) I had before.

Congratulations et Merci !

Franz

  Are you sure? yes | no

jp cocatrix wrote 04/04/2017 at 12:50 point

Thanks.
Yes, a bit hard to code but so exciting...

  Are you sure? yes | no

vanilinman wrote 04/01/2017 at 23:01 point

I solved the problem of crackles.I shorten the loop of wires between the modules (I connected without a breadboard).Thanks for the tips.

  Are you sure? yes | no

vanilinman wrote 04/01/2017 at 21:48 point

Thank you. You are super. It began to play. Please tell me how to get rid of crackles in the headphones. I tried various sources of power, it does not help.

  Are you sure? yes | no

jp cocatrix wrote 04/01/2017 at 21:52 point

I don't have this problem.

Check the ground wires (try another gnd entry may be) and try to short it (and all other....
Enjoy.

JP

  Are you sure? yes | no

vanilinman wrote 04/01/2017 at 20:54 point

Hello friends. Help is needed. I picked up the radio for Wemos D1 Mini following the instructions, but it does not want to play. The port writes:
##CLI.STOPPED# from playStationInt
##CLI.NAMESET#: 1 Record
##CLI.URLSET#: air.radiorecord.ru:8101/rr_320
##CLI.PATHSET#: /Icecast 2.3.3-kh10
##CLI.PORTSET#: 80
##CLI.OVOLSET#: 104
##CLI.STOPPED# from clientConnect

##CLI.VOL#: 254

  Are you sure? yes | no

jp cocatrix wrote 04/01/2017 at 21:02 point

url: air.radiorecord.ru

Port: 8101

Path: /rr_320

And it will work.

##CLI.STOPPED# from Post instant_play
##CLI.URLSET#: air.radiorecord.ru
##CLI.PATHSET#: /rr_320
##CLI.PORTSET#: 8101
##CLI.OVOLSET#: 0
##CLI.VOL#: 72
##CLI.ICY0#: Radio Record
##CLI.ICY4#: Dance
##CLI.ICY5#: 320
##CLI.ICY7#:  ice-samplerate=44100;ice-bitrate=320;ice-channels=2
##CLI.PLAYING#
##CLI.META#: Bounce Inc - Faith

  Are you sure? yes | no

Thomas wrote 02/18/2017 at 09:50 point

Hi JP, how is the correct Syntax to Change UART Baud over Browser?

  Are you sure? yes | no

jp cocatrix wrote 02/18/2017 at 09:54 point

  Are you sure? yes | no

Thomas wrote 02/18/2017 at 10:05 point

Hi JP, i already found but dont understand. Is it 192.168.2.136/sys.uart("19200") for example? This Dont Work so i guess my Syntax ist wrong

  Are you sure? yes | no

jp cocatrix wrote 02/18/2017 at 10:11 point

Two different interfaces: 
On browser:

192.168.2.136/?uart   revert the uart to 115200 until a reset. Useful in case you don't remind the current speed.

But on the uart interface (serial on tx rx)
sys.uart("115200")
Or other speed to change the uart baud rate on the next reset and forever until another sys.uart command.

115200 is the default. Before connecting a display controller, you must change to 28800.

  Are you sure? yes | no

Thomas wrote 02/18/2017 at 10:23 point

Ok, its a pitty. I  thought it could be adjusted on browser also. Is it possible to read the curren setting of baud on the browser? I unfortunatly have no communication between display controller and Esp . And want to check this first before Disassemble my Radio to connect it to a computer.

  Are you sure? yes | no

Thomas wrote 02/20/2017 at 11:07 point

Hi JP i know that your Standard setting is 28800. But i changed it both to 19200 because 28800 is not selectable with Arduino Serial Monitor. This works fine for me, also with IR Receiver on a pro Mni with 8 Mhz and 3,3 Volts.

In the past i had sometimes trouble with self changing settings on the Baudrate.

But in this case i checked now with computer, it hasnt changed.  I detached the esp Module and mount it again, and now Display works again.

It seems that my build on a protoboard is not much better than on a breadboard.

Regards

Thomas

  Are you sure? yes | no

Sergio wrote 02/13/2017 at 17:01 point

Hi JP, its posible to replace the VS1053 by a Bluetooth, to play the streams on some audio equipments or BT earphones?

  Are you sure? yes | no

jp cocatrix wrote 02/13/2017 at 17:17 point

To replace the vs1053? No, absolutely no, it is the stream decoder (mp3 aac etc).
But you can add a bluetooth transmitter after to send audio.
http://www.ebay.com/itm/EEEKit-Bluetooth-Transmitter-Receiver-Wireless-A2DP-Stereo-Audio-Music-Adapter-/192080524398
https://www.aliexpress.com/item/Bluetooth-launch-module-CSR57E6-bluetooth-audio-transmitter-module-DC5-24V/32780319150.html?spm=2114.01010208.3.25.IYofEc&ws_ab_test=searchweb0_0,searchweb201602_4_10065_10068_10000074_10000032_119_10060_10062_10056_10055_10000062_10054_10059_10099_10000013_10103_10102_10000016_10096_10000056_10000059_10052_10053_10107_10050_10106_10051_10000097_10000094_10000053_10000007_10000050_10084_10000100_10083_10000047_10080_10082_10081_10110_10111_10112_10113_10114_10115_10037_10033_10000041_10000044_10078_10079_10077_10000038_10073_10000035_10122_10121,searchweb201603_10,afswitch_2,ppcSwitch_5,single_sort_1_default&btsid=009badba-8b67-45c2-af4c-2ccb512e3c12
https://www.aliexpress.com/item/High-Quality-Mini-3-5mm-Bluetooth-Audio-Transmitter-A2DP-Stereo-Dongle-Adapter-for-TV-Mp3-Mp4/32783336194.html?spm=2114.01010208.3.83.nyyA3a&ws_ab_test=searchweb0_0,searchweb201602_4_10065_10068_10000074_10000032_119_10060_10062_10056_10055_10000062_10054_10059_10099_10000013_10103_10102_10000016_10096_10000056_10000059_10052_10053_10107_10050_10106_10051_10000097_10000094_10000053_10000007_10000050_10084_10000100_10083_10000047_10080_10082_10081_10110_10111_10112_10113_10114_10115_10037_10000041_10000044_10078_10079_10077_10000038_10073_10000035_10122_10121,searchweb201603_10,afswitch_2,ppcSwitch_5,single_sort_1_default&btsid=7bf82844-0d36-4b60-b01b-2619dfaded88

  Are you sure? yes | no

jan wrote 02/12/2017 at 15:40 point

Hi JP the ESP 8266 is not starting when I connect it to the USB port I have to press the reset button on the ESP 8266 to start it up  then its going oke

is it possible to get it started directly ? or by a command from Arduino

Is it possible to get time information sent to tx

  Are you sure? yes | no

jp cocatrix wrote 02/12/2017 at 21:29 point

Not sure to be able to do something for that. May be a weak usb?.
It works ok here.

The time is only on the browser for the moment. Do you need the time for displaying on the lcd?

  Are you sure? yes | no

jan wrote 02/12/2017 at 21:36 point

Yes i like the time on the Nextion diplay

  Are you sure? yes | no

jan wrote 04/15/2017 at 19:18 point

Thanks JP for the time for the display I not yet have it fix for my self butt will at it soon to the screen.

  Are you sure? yes | no

Similar Projects

Does this project spark your interest?

Become a member to follow this project and never miss any updates