Close

Noise

A project log for ZRTP Hardphone

A ZRTP Hardphone for secure voice communications

YagoYago 06/17/2014 at 08:584 Comments

Made a new box, put everything inside and wired it. 

So cool, I thought.

Then, plugged it to the power and find out that you can listen the radio on the ring speaker. And some other noises too.

After reading the Ganssle article about analog noise made a few tests to isolate the source. I thought that the problem comes from the mains power supply and the nearby powerful AM stations. Can hear the radio even with the input cable disconnected.

Also there is no protective earthing on my house (or neighborhood).

Installed the amp inside a metal box and moved the power supply further, but the noise is still there.

Discussions

Yago wrote 12/08/2014 at 17:14 point
Thank you for your comments, missed them until today. Tried with another cheap amp and the noise is almost gone. Almost because now it is connected to the raspberry sound output and while compiling or doing other work I can hear the processor interferences.

Will save this comments for future debugging.

  Are you sure? yes | no

nrx wrote 07/08/2014 at 05:37 point
Is it the same on the onboard audio output? have you tried another amp or headphones?

  Are you sure? yes | no

zakqwy wrote 06/17/2014 at 17:29 point
Have you tried using shielded cable for the signal-level lines going in to the amp? Also, can you try powering the unit using a battery (temporarily) to see if the noise is coming from the power supply?

  Are you sure? yes | no

Yago wrote 06/17/2014 at 09:36 point
If you know what may I be doing wrong, please leave a comment.
Thanks!

  Are you sure? yes | no