Close
0%
0%

Z80-MBC2: 4ICs homemade Z80 computer

8MHz Z80, 128kB banked RAM, RTC, Disk on SD, Basic and Forth interpreters, CP/M 2.2 and 3, cross Assembler and C (SDCC) toolchains

Similar projects worth following
The Z80-MBC2 is an easy to build Z80 SBC (Single Board Computer).

It is the "evolution" of the Z80-MBC (https://hackaday.io/project/19000-a-4-4ics-z80-homemade-computer-on-breadboard), with a SD as "disk emulator" and with a 128KB banked RAM for CP/M 3 (but it can run CP/M 2.2 too).

It has an optional on board 16x GPIO expander, and uses common cheap add-on modules for the SD and the RTC options. It has an "Arduino heart" using an Atmega32A as EEPROM and "universal" I/O emulator (so a "legacy" EPROM programmer is not needed).

It is a complete development "ecosystem", and using the iLoad boot mode it is possible cross-compile, load and execute on the target an Assembler or C program (using the SDCC compiler) with a single command (like in the Arduino IDE).


* * HARDWARE OVERVIEW * *

The needed ICs for the "base system" are:

  • Z80 CPU CMOS (Z84C00) 8Mhz or greater
  • Atmega32A
  • TC551001-70 (128kB RAM)
  • 74HC00

If you want the 16x GPIO expansion (GPE option) add a MCP23017 too.

The schematic and the BOM are attached in the Files section. The MCU Atmega32A is used as universal I/O subsystem, as Eeprom, and as reset and 4/8MHz clock generator for the Z80 CPU.
Inside the Atmega32A it is flashed an Arduino bootloader taken from here, and it is possible to use the Board Manager of the Arduino IDE to "import" it.

Flash the Arduino bootloader at first (with the method you prefer), next you can upload the IOS "sketch" (the I/O Subsystem that interacts with the Z80 bus and "virtualizes" the EEPROM and all the peripherals seen by the Z80 CPU) using Arduino IDE.

You can use the on board ICSP port J3 (also called ISP port) to write the bootloader, but remember to disconnect any other connector when using it. Also both SD and RTC modules (if present) must be removed from the board when the ICSP port is in use.

As clock source for the Z80 CPU it is used the 16MHz Atmega32A oscillator, so the "external 16MHZ osc." bootloader variant must be chosen when flashing the bootloader from the Arduino IDE!.

The 74HC00 is used as RS flipflop to stop the Z80 CPU during I/O operation, giving the needed time to the Atmega32A to interact with the Z80 bus, and as part of the MMU.

Note that only the CMOS version of the Z80 CPU can be used here. This because only CMOS version, under given condition that are respected in this schematic, has logical levels compatibles with Atmega32A and 74HC00.

... Read more »

S220718-R190918_IOS-Z80-MBC2.zip

The sketch for the IOS (with the needed libraries). Unzip into a folder and open the .ino file (with Arduino IDE). IOS is required for CP/M 2.2, CP/M 3.0 and QP/M 2.71 (the SD module is mandatory).

Zip Archive - 38.29 kB - 10/11/2018 at 16:54

Download

SD-S220718-R191018-v1.zip

The content of the microSD needed to run CP/M 2.2, CP/M 3.0 and QP/M 2.71 with IOS S220718-R190918

Zip Archive - 2.67 MB - 10/11/2018 at 16:53

Download

STARTREKV2.BAS

The famous game Super Startrek kindly debugged by a RetroBrew Computer Forum user. Play with Caps-Lock activated! Now the animation works...

bas - 20.18 kB - 08/07/2018 at 16:32

Download

TREKINST.BAS

Instructions for STARTREKV2.BAS

bas - 6.80 kB - 08/04/2018 at 21:48

Download

Examples with Basic.txt

Some examples showing the new "Virtual I/O Engine" with the stand-alone 8K Basic interpreter.

plain - 4.07 kB - 07/31/2018 at 20:57

Download

View all 10 files

  • 1 × See the file "A040618 BOM v2.ods" in the FILES section.

  • CP/M 3 up and running on the Z80-MBC2!

    Just4Fun10/11/2018 at 06:58 0 comments

    With the last IOS revision and the corresponding SD files "pack" there is one more option: the CP/M 3.0!

    With CP/M 3.0 it is possible use the 128KB banked RAM to have a wider user area (TPA) for programs and a more "evoluted" OS.


    TWO VERSIONS

    Just as example of how it is easy with CP/M 3.0 manage multiple configurations, I've done also a "non-banked" 64KB version. The switch from one version to the other can be done simply running a batch from the console itself.

    I've prepared two simple batch files to do that. From drive A: the command:

    submit sys64

    will set the 64KB "non-banked" version and than reboot the system.

    To activate again the 128KB "banked" version give the command (from drive A:):

    submit sys128

    NEW DISKDEFS FILE

    To use cpmtools or cpmtoolsGUI with the virtual disks of the CP/M 3.0 environment, you must update the DISKDEFS definition file (from the SD in the folder <SD>/cpmtools/) and use the "z80mbc2-cpm3" entry for all the 16 disks:

    Please note that for the CP/M 3.0 environment all the 16 virtual disks have the same structure and for this there is only one entry for all the CP/M 3.0 virtual disks.


    AUTOEXEC

    The AUTOEXEC switch for CP/M 3.0 works in a different way from the CP/M 2.2 and QP/M 2.71 implementations.

    Now there is a custom utility (AUTOEXEC) that checks the IOS flag and sets the exit code accordingly (using the BDOS function 108). This allow to use the CP/M 3.0 batch conditional execution (see the CP/M 3 Programmer Guide par. 1.6.3) to run any wanted command or program based on the status of the IOS AUTOEXEC flag.

    I've prepared an example using an other CP/M 3.0 feature, the "PROFILE.SUB" batch that is automatically executed at cold boot (if it exists). To activate it (in the drive A:) rename the file PROFILE.SU as PROFILE.SUB with the command:

    ren profile.sub=profile.su

    Now you can see how it works setting the AUTOEXEC flag on or off with the IOS "Select boot mode or system parameters" menu.

  • QP/M 2.71 up and running (with IOS multi-boot management...)!

    Just4Fun09/17/2018 at 18:26 0 comments

    With the last IOS revision and the corresponding SD files "pack" there is an interesting alternative to CP/M developed by MICROCode Consulting that supports also file timestamping, and it is 100% CP/M 2.2 "compatible".
    MICROCode Consulting has released the original installation files and all the documentation in their site with the "restricted usage" condition, that means free for non-commercial use and for personal use only.

    To enable timestamping (see upper screenshot) you need to install the optional RTC module.
    I suggest to read the QP/M documentation for the various commands (see the Downloads section in their site).


    AUTOEXEC

    The QP/M uses for the batch file the .QSB extension. So the AUTOEXEC file is now renamed AUTOEXEC.QSB. To enable the AUTOEXEC execution after the cold boot change the corresponding state to ON from the usual IOS boot selection menu. In the drive A: there is an example of AUTOEXEC.QSB file ready to run.


    IOS MULTI-BOOT MANAGEMENT

    Now the IOS has a new entry (8) in the boot menu to manage the OS multi-boot configuration:

    Each OS is associated with a set of virtual disks called "Disk Set", and changing the "Change Disk Set..." entry (8) will switch all the virtual disks of his "environment".

  • CP/M 2.2 up and running on the Z80-MBC2!

    Just4Fun09/08/2018 at 18:24 0 comments

    The new IOS is out, and the CP/M 2.2 OS with it, and 16 disks are available (from A: to P:), each 8Mbyte large.

    With IOS (not for IOS Lite) the SD module is mandatory to run not only CP/M 2.2 but also for the stand-alone Basic and Forth interpreters. You need a microSD card (FAT16 and FAT32 are both supported) to store the content of the SD zip file, retaining the directory structure.

    Pay attention on how the modules are inserted because their positions are fixed and absolutely not swappable (see the upper photo).

    To add, extract or delete files inside a virtual disk (virtual disks filenames on SD are "DS0Nxx.DSK", where "xx" is the disk number) it is possible use the cpmtools or cpmtoolsGUI utilities, with the diskdefs file in the \cpmtools directory of the SD zipped file.

    I suggest to use  cpmtoolsGUI (only for Windows) because is very easy.

    Unzip it into a folder and put the diskdefs file in the same folder.
    Select "z80mbc2-d0" only for disk 0, and "z80mbc2-d1" for the others (disk 1 - 15):

    NOTE: use cpmtoolsGUI only to add, extract or delete files inside a virtual disk. Not try to create new virtual disks files with cpmtools or cpmtoolsGUI because further processing is required for a valid virtual disk file.

  • How use the ICSP port with the USBasp programmer under linux to burn the bootloader

    Just4Fun07/27/2018 at 15:57 0 comments

    A cheap and easy way to burn the Arduino bootloader is to use an USBasp programmer that is commonly available:

    The USBasp is also capable to give the power to the "target" using the VCC pin, but remember to check that the JP1 jumper is set to provide 5V to the target (as shown in the photo).

    Please note that the pinout of the USBasp is a little different from the "standard" ICSP (os ISP) pinout:


    In the previous picture it is possible see that pins 4 (TXD) and 6 (RXD) are not at GND as expected  by the standard ICSP port, and pin 3 is not NC.

    See the following picture showing the standard 10 pin ICSP pinout:


    So you must consider this when connecting the USBasp to the 6 pins ICSP port (J3) on the Z80-MBC2 (see the schematic):

    To avoid problems I suggest to use as GND pin 10 of the USBasp connector, and connect the other pins (VCC, MISO, MOSI,SCK, RST) accordingly.

    An handy way to connect the USBasp to the 6 pin ICSP port (J3) of the Z80-MBC2 could be to use a commonly available "10pin to 6pin" adapter like this:


    but you cannot use it "as is" because its internal connections are done for a "standard" ICSP port, and we have seen that the USBasp connector differs from the standard one.
    The schematic of the adapter shows that isn't compatible "as is" with the UABasp connector:


    To use it is a good idea isolate the pins 4, 5 and 6 cutting the trace on the PCB of the adapter that connects those pins together, and then check with a tester.
    In the following photo are shown the three cuts (thin red lines inside the green "circle") to do:


    BURNING THE BOOTLOADER FROM ARDUINO IDE:

    To easily burn the bootloader follow these "quick and dirty" steps (tested on a linux Mint OS with Arduino IDE 1.8.5):

    STEP 1: Connect the 10 pins connector of the USBasp programmer to the 6 pins ICSP port (J3) of the Z80-MBC2 (using wires or a modified adapter as discussed before);

    STEP 2: Verify carefully that any other connector of the Z80-MBC2 is not used, and verify that both the SD and RTC modules (if present) are removed from the board;.

    STEP 3: Only at this point connect the USB side of the USBasp programmer to an USB port of your workstation;

    STEP 4: Open a "terminal" window on your workstation and go to the directory where there are the Arduino IDE executables, and get the root privileges with the command:

    sudo su

    then run the Arduino IDE with the command:

    ./arduino

    STEP 5: Because Arduino IDE is running as the root user it is necessary re-install the "core" for the Atmega32. Open the Board Manager as you already did (anyway  the guide is here). Note that you must do this step only the first time you execute the Arduino IDE as root;

    STEP 6: Now from the Tools menu of Arduino IDE select "Atmega32" as "Board", "16 MHz external" as "Clock", and "USBasp" as "Programmer". Then you can burn the right bootloader (without playing with the FUSE setting) selecting "Burn Bootloader" from the same "Tools" menu.

    All done!

View all 4 project logs

Enjoy this project?

Share

Discussions

villaromba wrote 10/13/2018 at 08:52 point

If you do need to use the TL866 direct, the only fuse settings you need to select are :-  SUT0, SUT1, SPIEN, BOOTSZ1, BOOTSZ0 - (this gives CF & D9) - make sure everything else is not selected. I've used these settings every time - and every time a success!!!

  Are you sure? yes | no

scottie4442 wrote 10/12/2018 at 13:56 point

OK, just got the new IOS for cp/m 3 uploaded and copied the sd image to a blank fat32 formated sd card.  when I boot the z80-mbc2 I get the menu. I set the rtc to the correct time and change diskset to 2, the CP/M 3 set. when I try to boot the os I get Z80 is running from now I either get the prompt again and cannot type or I get nothing, it looks like it just hangs. I have run down the menu and I get this same behavior from basic, forth, CP/M 2.2, QP/M 2.71 and CP/M 3.0. not sure what to do now.

  Are you sure? yes | no

Just4Fun wrote 10/12/2018 at 14:20 point

Try to flash IOS-LITE ( https://cdn.hackaday.io/files/1599736844284832/S220618_IOS-LITE-Z80-MBC2.ino ) and tell me if the various options work...

PS: this is the first time you run the board...?

  Are you sure? yes | no

scottie4442 wrote 10/12/2018 at 15:43 point

OK, I uploaded the IOS-LITE and I get the same thing, when I try to load basic, forth or the iload, I get Z80 is running from now and then nothing it just sits there and I get nothing else.  I tried to reset and the menu come back but when I make a selection it does the same thing.  I have check that my soldering is ok and that the chips are seated properly.

  Are you sure? yes | no

Just4Fun wrote 10/12/2018 at 16:11 point

An other user had exactly the same issue... it was a faulty SRAM (it could be a faulty Z80 or 74HC00 too, but the SRAM is at first place).

The Atmega seems work properly.

PS: Are you sure to have a CMOS Z80...?

  Are you sure? yes | no

scottie4442 wrote 10/12/2018 at 16:47 point

chips are :

Zilog z84c0008PEG

Alliance AS6C1008-55PCN

Atmel ATMEGA32A

TI SN74HCT00N

MCP23017-E/SP

All these are brand new chips from Mouser

  Are you sure? yes | no

Just4Fun wrote 10/12/2018 at 16:54 point

Chips numbers seem ok.

Which method have you used to flash the bootloader?

  Are you sure? yes | no

scottie4442 wrote 10/12/2018 at 21:57 point

with usbasp and arduino ide. I did remove the rtc and sd card reader as suggested and plugged the usbasp in according to the info above.  I also have a tl866 programmer that I can program the atmega32a with but I was not sure of the fuse settings.

  Are you sure? yes | no

Just4Fun wrote 10/13/2018 at 09:36 point

Ok, given that all seems as expected and excluding ghosts and black magic, the suspects are on the SRAM and CPU again...

I've prepared a IOS-LITE modified test version to test the CPU only. This simple test will force the Z80 into HALT, so the HALT led will turn on. The SRAM is not used, so this test can be run also without any SRAM chip installed.

The sketch is downloadable from here: https://drive.google.com/open?id=1irVxE3IF_Ilte1c547ZSuzLTaaWIfeeC

If you press RESET, the HALT led will turn off for about one second, then it will turn on again.

  Are you sure? yes | no

scottie4442 wrote 10/13/2018 at 13:32 point

OK, I think I found part of the problem (I am an idiot sometimes).  I went back to start fresh and  when I did the boot loader step I realized there is a USBasp and a USBasp(MightCore). I chose the USBasp(MightCore) this time and it is getting further seem like, but now when I try to load Basic, Forth or iLoad, the IOS and Halt led's are solid and the DMA is blinking occasionally the goes out. Hopefully this is progress. Oh I used IOS again for this not IOS-LITE

  Are you sure? yes | no

Just4Fun wrote 10/05/2018 at 22:00 point

  Are you sure? yes | no

Jay Sissom wrote 10/05/2018 at 18:58 point

Hello, I can't find the vendor and model number of the RTC and SD card adapters.  Can you  please provide that?  Thanks.

  Are you sure? yes | no

scottie4442 wrote 09/30/2018 at 18:26 point

I see an your info that you say to use cpmtools or cpmtoolGUI to make the sd cards to run cpm 2.2 and/or qpm 2.71. is there some place that shows the steps by step to create the d card from empty, I have a 32gb sd card formatted with fat32 and not sure what to do to start the process.

  Are you sure? yes | no

Just4Fun wrote 09/30/2018 at 18:37 point

Hi, to run CP/M or QP/M you only need to unzip the SD zipped file into the SD with your PC.

Cpmtools or cpmtoolGUI are only needed to add, extract or delete a file  * inside * a CP/M or QP/M virtual disk.

  Are you sure? yes | no

scottie4442 wrote 09/30/2018 at 20:07 point

ok, that lets me know what I needed.  I have worked on trs-80, apples, etc, been in computer for 40 years, just not worked with cp/m in 30 years so having ro recall with my OLD brain how this works.

  Are you sure? yes | no

Just4Fun wrote 09/30/2018 at 21:09 point

Great! If you want a "preview" of CP/M 3 you can try this too: https://twitter.com/Just4Fun_J4Fun/status/1045730075398803456

  Are you sure? yes | no

Boris wrote 09/26/2018 at 10:17 point

I built mine and after a lot of debugging with a scope, something is very strange.  For debugging purposes I wrote a sketch to ask for pin number and 1/0 value to place on any pin, and exercising it shows that all the correct signals propagate properly from the ATMEGA to everywhere they should.  But during this, something really unusual is happening: the IOREQ pin of the Z80 activates low for no apparent reason.  I mean, it just received the "single-pulses reset".  There is no clock coming -- pin 6 is sitting at 0.  Nothing is happening, and the ATMEGA is just waiting for console input, yet somehow, spontaneously, after a few seconds Z80's pin 20 pulls to 0.  I am at the end of my wit...

  Are you sure? yes | no

Just4Fun wrote 09/26/2018 at 11:33 point

I have no idea about your test, but reading your note it seems that you have some Atmega GPIO pins left in HiZ.... (I mean as INPUT without PULLUP).

  Are you sure? yes | no

villaromba wrote 09/17/2018 at 22:09 point

QP/M  - Love the progression of this project., particularly the ease of getting software onto the SD card via CPMTOOLS guii - a good find!!!

  Are you sure? yes | no

john wrote 09/11/2018 at 23:54 point

What are you guys using for terminal emulation settings?  Specifically, have you gotten backspace to work?  

  Are you sure? yes | no

Just4Fun wrote 09/12/2018 at 09:48 point

Using Tera Term it works out of the box (if I remember well)...

  Are you sure? yes | no

john wrote 09/12/2018 at 23:38 point

Thanks - I tried TeraTerm and it works fine.  Was using Putty and had to change the keyboard to send ctrl-H instead of ctrl-? under keyboard settings.  That makes things much easier!

  Are you sure? yes | no

Jeff Davis wrote 09/09/2018 at 08:37 point

Just4Fun: On the BOM sheet, RN1 and RN2 are listed as a SIP8 (8 pins), but the board has 9 pins (8 resistor + 1 common 5v). Should the sheet say SIP9 (which has 9 pins, 8 resistors and 1 common)?

  Are you sure? yes | no

Just4Fun wrote 09/09/2018 at 10:44 point

Yes is SIP9 (which has 9 pins, 8 resistors and 1 common). I'll change it in the BOM...

  Are you sure? yes | no

Jeff Davis wrote 09/05/2018 at 06:48 point

Just4Fun: I just ordered 10 PCBs (in black) from pcbway, thanks for setting up that shared project to make it easy to order. When I ordered, buying 10 boards was the same price as 5, with a little extra shipping cost.

I'm looking at ordering parts now, and I see on the BOM that C1,C2,C5,C6,C8,C9,C12 are all ".1uF", while C10 is "0.1uF". Are those all 0.1uF, or is one of the values listed wrong?

  Are you sure? yes | no

Just4Fun wrote 09/05/2018 at 07:36 point

No, it's the same value... (.1uF = 0.1uF). Because it is on an other sheet, I've forgotten to follow the same "convention" of the other sheet.... :)

Don't miss the Twitter "channel" with "some" preview and "spoilers": https://twitter.com/Just4Fun_J4Fun

  Are you sure? yes | no

Norihiro Kumagai wrote 08/30/2018 at 02:54 point

Just for your information,  in Japan, building Z80-MBC2 becomes quite popular (among oldboys, like me:-),  a kind vendor "orangepico" in Japan start to provide  PCB's, so barriar on getting PCB in Japan becomes quite low.  I am quite sorry all of the tweets are written in Japanese, but almost all tweets includes their pictures with short messages, I hope you could feel our delightful moments.

  Are you sure? yes | no

Just4Fun wrote 08/30/2018 at 18:58 point

Thanks you very much for you kind message... :)

  Are you sure? yes | no

Cyril V. wrote 08/30/2018 at 00:16 point

I just got my PCBs, they look really good (the solder mask is black).

I got couple to spare. I think selling 2 for $5 plus shipping, PM if interested.

  Are you sure? yes | no

villaromba wrote 08/28/2018 at 13:38 point

The message you get - is that after selecting it or does it just default to that?  OR Do you get full menu if you hold user key dow, then hold reset for a moment - release it and then release user key? If so can you select anything at all from keyboard?

  Are you sure? yes | no

Peabody1929 wrote 08/28/2018 at 19:21 point

After pressing just reset I get:

Z80-MBC2 - A040618
IOS-LITE - I/O Subsystem - S220618

IOS: Z80 clock set at 4MHz

IOS: Loading boot program... Done
IOS: Z80 is running from now


After pressing reset and user and release I get:

Z80-MBC2 - A040618
IOS-LITE - I/O Subsystem - S220618

IOS: Z80 clock set at 4MHz

IOS: Select boot mode or system parameters:

 0: No change (->1)
 1: Basic
 2: Forth
 3: iLoad
 4: Change Z80 clock speed (4/8MHz)

Enter your choice >

After pressing "1" at the prompt I get:

Enter your choice >1  Ok
DEBUG: BootImageSize = 7603
DEBUG: BootStrAddr = 0
IOS: Loading boot program... Done
IOS: Z80 is running from now

  Are you sure? yes | no

Just4Fun wrote 08/28/2018 at 20:46 point

Which method have you followed to flash the bootloader?

  Are you sure? yes | no

Peabody1929 wrote 08/27/2018 at 18:30 point

I finished building my board.  It starts up, outputs messages to the serial monitor but seems to stop after the message: 

"IOS: Z80 is running from now".  

The Z80 clock is set at 4MHz

The boot mode is 1: Basic.

What should I do next to debug the issue?  

  Are you sure? yes | no

Just4Fun wrote 08/27/2018 at 19:49 point

Which method have you followed to flash the bootloader?

  Are you sure? yes | no

Peabody1929 wrote 08/31/2018 at 02:54 point

I have tried two methods of flashing the bootloader.  Each time used a different ATmega 32 part.  Both times the USB interface was a USBTinyISP V2.0.  First time it was connected via a 10 pin cable to a ATmega32 dev board with a 40 pin ZIF, a 10 pin socket and all the pins brought out to headers.  The second time was using a 6 pin cable connected to the ISP connector on the MBC2 board.  In the Arduino IDE v1.8.5 selected the programmer as USBTinyISP (MIghty Core) and click Burn Bootloader.  There were no error messages and the flash was successful.

Unfortunately this made no difference in behavior.

One difference is that I am using a Z84C00020PEC.  This is a 20MHz Z80.  Is there a possibility of a narrow clock pulse glitch that a 8MHz part would never see?

Finally, I think the ATmega32 is operating correctly.  I plugged in a MCP23017 and a new message appeared: "IOS: Found GPE Option".

  Are you sure? yes | no

Just4Fun wrote 08/31/2018 at 07:31 point

I'm using the same Z80 (Z84C00020PEC) on Z80-MBCs and Z80-MBC2s without problems...

And the method you use to flash the bootloader seems correct to me (I use the USBasp, but the USBTinyISP should be ok because you are using the Arduino IDE "facility" to burn the bootloader, so should be not possible to have fuse bits configuration errors because they are managed by the IDE...).

Try to change a different Atmega32A, just to be sure that your part is not faulty.

After that it seems that the problem can be the CPU or the SRAM, because you arrive at the point when the program should be loaded into SRAM and the Z80 starts to execute it.

  Are you sure? yes | no

Peabody1929 wrote 09/01/2018 at 01:02 point

IT WORKS!!!!  I replaced every chip except the SRAM.  Following your suggestion, I replaced the SRAM.  The board now works perfectly; BASIC comes up and runs.   I am a happy camper.  Thank you for the help!

Tom

  Are you sure? yes | no

Just4Fun wrote 09/01/2018 at 07:47 point

Great! Can you tell me the exact part name  of the faulty SRAM?

BTW: Thinking to add a SRAM test....

  Are you sure? yes | no

Peabody1929 wrote 09/01/2018 at 18:32 point

The faulty SRAM part number is: HM628128ALP-7  The replacement part is: HM628128LP-12.  The replacement part is an older generation and slower part.

If you like, I can send you the failing part by mail.

P.S.  I have some HM628128BLP-7 parts as well.  Perhaps in the next build I will give these a try.

  Are you sure? yes | no

Just4Fun wrote 09/03/2018 at 09:40 point

Thanks, but it is enough if you could just keep it. So if I have the time to write a memory test it is possible to use the faulty SRAM for testing...

BTW: may be that this can interest you: https://twitter.com/Just4Fun_J4Fun/status/1036289202265247745 :)

  Are you sure? yes | no

Julian wrote 08/26/2018 at 20:24 point

Thinking of using this design as a basis for experimentation -- do you know if it's likely to run OK on breadboard, or is the PCB essential?

  Are you sure? yes | no

Just4Fun wrote 08/27/2018 at 15:44 point

Yes it can be done. Just the quartz oscillator could be "critical" on the breadboard, but if you use the internal oscillator (8MHz) you shouldn't find any problem.

You can give a look to the previous Z80-MBC on breadboard too (https://hackaday.io/project/19000-a-4-4ics-z80-homemade-computer-on-breadboard).

  Are you sure? yes | no

villaromba wrote 08/11/2018 at 07:51 point

Built up my board yesterday - no output!! until I realised I had clock fusebits inverted!! Reprogrammed AVR (TL866) and then it worked immediately, pleased all hardware/soldering was 100%!!. Put my AVR on a ZIF, just fits nicely. RTC should be here over weekend. I already have a Pololu SD so hoping that will be ok when ready to fit. Thanks again J4F for another excellent design and look forward to where it might develop.

  Are you sure? yes | no

Just4Fun wrote 08/11/2018 at 08:02 point

Thanks!

I think this may interest you... :) : https://twitter.com/Just4Fun_J4Fun/status/1027158962242772992.

PS: Check carefully that the Pololu SD has the 3.3V regulator and level shifters on board, and how to connect it as it is different from that one I've used here.

  Are you sure? yes | no

villaromba wrote 08/11/2018 at 10:39 point

Great!!! - it works with the Pololu SD card, with level shifters (all I had) just needed to make small adapter to ensure pin compatibility. 

  Are you sure? yes | no

villaromba wrote 08/12/2018 at 15:42 point

What will be the longer term plan for CP/M files on the SD Card e.g will it be able to read files from Peter Schorns Z80 simulaior (https://schorn.ch/)  or Z80 pack (https://www.autometer.de/unix4fun/z80pack/)?  OR ???

  Are you sure? yes | no

Just4Fun wrote 08/12/2018 at 16:34 point

The first link is interesting as i didn't know anything about it. (the second is well known).

About the SD,  I'll use "disk files" each equivalent to a disk of 512 tracks of 32 sectors. A sector is 512 bytes large, as the SD physical sector. So any SW that can "understand" this can read/write files on it.

E. G. using cpmtools with the correct parameters will work (I hope...) :)

I've to manage a "deblocking" algorithm for CP/M2.2, because it can use natively only 128 bytes sectors (CP/M 3 can use 512 bytes sectors natively, as far I know...), and this will take "some" time...

  Are you sure? yes | no

Just4Fun wrote 08/05/2018 at 11:57 point

For those interested I've set up a twitter account to follow the "day by day" developments (and others things too)...: https://twitter.com/Just4Fun_J4Fun

  Are you sure? yes | no

Norihiro Kumagai wrote 08/05/2018 at 07:23 point

I have one comment, some N-MOS CPU also work well, at least, NEC upd780-1 works well on both Z80-MBC, and Z80-MBC2.  If someone have one or more N-MOS Z80, It might work on these boards.

  Are you sure? yes | no

Norihiro Kumagai wrote 08/05/2018 at 07:19 point

I built a PCB and see the BASIC prompt and run a Blink BASIC program.  Quite good.  Thank you very much. If you are interested in it, please refer my blog https://dip40.wordpress.com/  or my tweet (@tendai22plus).

  Are you sure? yes | no

Just4Fun wrote 08/05/2018 at 09:27 point

You have a very good blog. It's really a pleasure read it!

  Are you sure? yes | no

Just4Fun wrote 08/02/2018 at 17:02 point

HI all, and thanks for your comments!

Here IOS booting from SD: https://farm2.staticflickr.com/1793/43090760674_723f2eb475_o.png

Now starting to play with CP/M 2.2...

  Are you sure? yes | no

Similar Projects

Does this project spark your interest?

Become a member to follow this project and never miss any updates