Z80-MBC2: 4ICs homemade Z80 computer

8MHz Z80, 128kB banked RAM, RTC, Disk on SD, Basic and Forth interpreters, CP/M 2.2 and 3, cross Assembler and C (SDCC) toolchains

Similar projects worth following
The Z80-MBC2 is an easy to build Z80 SBC (Single Board Computer).It is the "evolution" of the Z80-MBC (, with a SD as "disk emulator" and with a 128KB banked RAM for CP/M 3 (but it can run CP/M 2.2, QP/M 2.71 and UCSD Pascal too).

It has an optional on board 16x GPIO expander, and uses common cheap add-on modules for the SD and the RTC options. It has an "Arduino heart" using an Atmega32A as EEPROM and "universal" I/O emulator (so a "legacy" EPROM programmer is not needed).

It is a complete development "ecosystem", and using the iLoad boot mode it is possible cross-compile, load and execute on the target an Assembler or C program (using the SDCC compiler) with a single command (like in the Arduino IDE).


The needed ICs for the "base system" are:

  • Z80 CPU CMOS (Z84C00) 8Mhz or greater
  • Atmega32A
  • TC551001-70 (128kB RAM)
  • 74HC00

If you want the 16x GPIO expansion (GPE option) add a MCP23017 too.

The schematic and the BOM are attached in the Files section. The MCU Atmega32A is used as universal I/O subsystem, as Eeprom, and as reset and 4/8MHz clock generator for the Z80 CPU.
Inside the Atmega32A it is flashed an Arduino bootloader taken from here, and it is possible to use the Board Manager of the Arduino IDE to "import" it.

Flash the Arduino bootloader at first (with the method you prefer), next you can upload the IOS "sketch" (the I/O Subsystem that interacts with the Z80 bus and "virtualizes" the EEPROM and all the peripherals seen by the Z80 CPU) using Arduino IDE.

... Read more »

The content of the microSD needed to run CP/M 2.2, CP/M 3.0, QP/M 2.71 and UCSD Pascal with IOS S220718-R280819. Adds the UCSD Pascal OS.

Zip Archive - 3.57 MB - 09/01/2019 at 16:12


The sketch for the IOS (with the needed libraries). Unzip into a folder and open the .ino file (with Arduino IDE). IOS is required for CP/M 2.2, CP/M 3.0, QP/M 2.71 and UCSD Pascal (the SD module is mandatory). Adds the UCSD Pascal OS. NOTE: now the default serial speed is 115200 bps.

Zip Archive - 38.32 kB - 09/01/2019 at 16:10



The sketch for the IOS in executable format (.HEX) with the bootloader. This executable file is intended for use with a programmer as the Atmel Ice or AVRISPmkII or others (Fuse bits: High Byte 0xD6, Low Byte 0xAF, Lock Byte 0xCF)

x-hex - 55.58 kB - 09/01/2019 at 16:10



The famous game Super Startrek kindly debugged by a RetroBrew Computer Forum user. Play with Caps-Lock activated! Now the animation works...

bas - 20.18 kB - 08/07/2018 at 16:32



Instructions for STARTREKV2.BAS

bas - 6.80 kB - 08/04/2018 at 21:48


View all 11 files

  • 1 × See the file "A040618 BOM v2.ods" in the FILES section.

  • UCSD Pascal for the Z80-MBC2!

    Just4Fun09/01/2019 at 15:45 3 comments

    Thanks to Michel Bernard (a member of the Z80-MBC2 User Group on FB) who did the porting, now UCSD Pascal is running on the Z80-MBC2!

    Michel Bernard originally used the trick to create a custom autoboot.bin file to be used with the "Autoboot" boot selection to load the OS.

    Because this porting is so cool, I've done a new IOS version and a new SD image to support UCSD Pascal in the same way as the others previous OS, adding a new "Disk Set" selection:

    To run UCSD Pascal you just need to update the new IOS and the new SD image (in the Files section) and select it from the usual "Select boot mode or system parameter" menu:

    In the new SD image there are two volumes (disks) SYS1: and SYS2:

    Here the execution of an example (SINE.CODE) already compiled on the SYS2: disk:

    In the folder "UCSD Pascal" inside the SD there are the original files and sources provided by Michel Bernard.
    A lot of documentation and books about UCSD Pascal can be found here.

  • uCom is out!

    Just4Fun05/29/2019 at 09:20 0 comments

    I've done a separate "project page" for uCom (RS232 add-on card for the Z80-MBC2) here.

    The uCom board, as the uTerm VT100 board, has a "transparent" USB-serial adapter connector, so you can upload firmware to the Z80-MBC2 (using Arduino IDE) or load an Intel-Hex file (with iLoad) or use XMODEM to exchange files with a PC (running a terminal emulator that supports XMODEM file transfer) while the uCom is in use.

    Both the "mixed" power supply scenarios (USB-serial adapter not powered from USB but Z80-MBC2 powered and vice-versa) are managed by the HW, so you don't need to worry about it.

    uCorm can be mounted horizontally or vertically to the Z80-MBC2.

    The 3D printed custom angled brackets .STL files are the same of the uTerm.

    Here connected with a "vintage" RS232 terminal (Ampex 210 relabeled Kyber):

  • FuzixOS preview: Unix for Z80!...

    Just4Fun05/21/2019 at 17:14 3 comments

    First test with FuzixOS on the Z80-MBC2 (many many thanks to Alan Cox...)!:

    Stay tuned...

  • uTerm is out!

    Just4Fun05/14/2019 at 07:40 0 comments

    I've done a separate "project page" for uTerm here.

    uTerm can be mounted horizontally or vertically to the Z80-MBC2.

    All the details including the 3D printed custom angled brackets .STL files are there.

    uTerm is a VT100 terminal with VGA out and  PS/2 keyboard with a power supply (for the Z80-MBC2 too). It has a "transparent" USB-TTL adapter connector, so you can upload firmware or load an Intel-Hex file (with iLoad) while the card is inserted. Both the "mixed" power supply scenarios (USB-TTL adapter not powered from USB but Z80-MBC2 powered and vice-versa) are managed. The video terminal is based on the ChibiTerm (

  • uCom preview: a RS232 adapter for the Z80-MBC2...

    Just4Fun04/05/2019 at 17:00 0 comments

    Currently working on a RS232 add-on card for the Z80-MBC2.

    As the uTerm board, it has a power supply for the Z80-MBC2 and a "transparent" USB-TTL adapter connector, so you can upload firmware or load an Intel-Hex file (with iLoad) while the card is inserted. Both the "mixed" power supply scenarios (USB-TTL adapter not powered from USB but Z80-MBC2 powered and vice-versa) are managed.

    Here connected to an Ampex 210 terminal (sold and relabeled by Kyber):

    Stay tuned...

  • New IOS for XMODEM support

    Just4Fun03/10/2019 at 10:54 4 comments

    Because some people requested to use the XMODEM protocol to exchange files through the serial port, I've added the support for this protocol into CP/M 2.2 and CP/M 3 (banked only).

    XMODEM needs a full 8 bit binary data transfer, and this is not possible with the CON port (the CP/M port used for the console) with a "legacy" CP/M system installation because the CP/M Alteration Guide says to strip the eight parity bit when reading a byte from the console input.

    More, because the Z80-MBC2 uses a virtual serial port without handshaking there is also a timing problem when dealing with the 128 bytes packets used by the XMODEM protocol.

    So the support to the XMODEM protocol has requested changes in the IOS and  in the CP/M BIOS, and also in the Arduino core to extend the serial input buffer.

    Please note that with the new IOS the default speed of the serial port is now 115200 bps.

    To have the XMODEM support active, before the update of the new IOS firmware and the new SD image (see in the Files section),  you have to manually create a new "board variant" in the Arduino IDE and then change the default Rx input buffer size to 128 bytes in the "core" of this new variant.

    If you aren't interested into the XMODEM support, you can simply update the IOS and the new SD image as usual  without the need to create the new board variant. In this case the XMODEM will not work in the receive direction, but only in the send direction (from the Z80-MBC2 to a PC with a terminal emulator).


    In the following I'll assume an Arduino IDE 1.8.5 installation on a linux host and the MightyCore ver. 1.0.8. Anyway I've tried to make the procedure enough general to be used for other versions too.

    The first thing is find the directory where the MightyCore is located.

    If you have installed Arduino IDE 1.8.5 and then installed the MighyCore with the Board Manager with the usual .json "pointer", the MightyCore is located in the "~/.arduino15/packages/MightyCore" directory:

    Now you must locate the "~/.arduino15/packages/MightyCore/hardware/avr/1.0.8/cores" directory (note that the "1.0.8" part of the directory name depends on the MightyCore version, and so can be a different number if you have a different version of the MighyCore):

    ... Read more »

  • uTerm preview: a VT100 terminal for the Z80-MBC2...

    Just4Fun12/28/2018 at 10:16 2 comments

    Currently working on a VT100 terminal with VGA out and  PS/2 keyboard with a power supply (for the Z80-MBC2 too). It has a "transparent" USB-TTL adapter connector, so you can upload firmware or load an Intel-Hex file (with iLoad) while the card is inserted. Both the "mixed" power supply scenarios (USB-TTL adapter not powered from USB but Z80-MBC2 powered and vice-versa) are managed. The video terminal is based on the ChibiTerm (

    Stay tuned...

    Working on a new revision (A071218-R250119):

    Waiting the new PCB, I'm playing with the current PCB "patched" to perform like the new one.
    Here a session with Wordstar 4 configured to use all the 30 rows of uTerm:

    In the photo you can see that also the serial-USB adapter is attached to the uTerm using the "transparent" port. This allows to use two keyboards and two monitors in the "same" time (one keyb and monitor attached directly to the uTerm, and another keyb and monitor of the terminal emulator on a PC connected with the serial-USB). This allows also to use XMODEM (e.g. between the Z80-MBC2 and a PC) or to flash the Atmega firmware with the uTerm connected.

    Or you can use the monitor attached to the uTerm and the keyboard of the terminal emulator on a PC. This is exactly the "configuration" I used in the photo to make the test (as you can see, there isn't any keyb attached to the uTerm).

    Catchum demo with uTerm (a sort of Pacman...). Leaving the game alone, after a while the "demo mode" starts:

    Here last version assembled horizontally with the Z80-MBC2:

    Currently making custom 3D printed mounting brackets for a solid vertical assembling:

  • Overclocking the Z80-MBC2...

    Just4Fun11/02/2018 at 09:51 4 comments

    Because the Mighty Core gives the chance to choice a 20MHz bootloader, I've decided to try to "overclock" the Atmega32A using a 20MHz quartz:

    You don't need others HW changes, just use a 20MHz quartz instead of a 16MHz one. The Z80 clock speed will be at 10MHz.

    You have to select the "20MHz external" option in the "Toos" menu of Arduino IDE before flashing the 20MHz bootloader:

    Of course you need to load the sketch again (using the "20MHz external" option). IOS will display the new clock speed:

    Remember that using a 20MHz quartz you are out of the Atmega32a specifications (the Atmega32a is rated at 16MHz max.), so you are in a "grey area" where things "may works"...

  • CP/M 3 up and running on the Z80-MBC2!

    Just4Fun10/11/2018 at 06:58 0 comments

    With the latest IOS revision and the corresponding new SD image (see the Files section) there is one more option: the CP/M 3.0!

    With CP/M 3.0 it is possible use the 128KB banked RAM to have a wider user area (TPA) for programs and a more "evoluted" OS.


    Just as example of how it is easy with CP/M 3.0 manage multiple configurations, I've done also a "non-banked" 64KB version. The switch from one version to the other can be done simply running a batch from the console itself.

    I've prepared two simple batch files to do that. From drive A: the command:

    submit sys64

    will set the 64KB "non-banked" version and then reboot the system.

    To activate again the 128KB "banked" version give the command (from drive A:):

    submit sys128


    To use cpmtools or cpmtoolsGUI with the virtual disks of the CP/M 3.0 environment, you must update the DISKDEFS definition file (from the SD in the folder <SD>/cpmtools/) and use the "z80mbc2-cpm3" entry for all the 16 disks:

    Please note that for the CP/M 3.0 environment all the 16 virtual disks have the same structure and for this there is only one entry for all the CP/M 3.0 virtual disks.


    The AUTOEXEC switch for CP/M 3.0 works in a different way from the CP/M 2.2 and QP/M 2.71 implementations.

    Now there is a custom utility (AUTOEXEC) that checks the IOS flag and sets the exit code accordingly (using the BDOS function 108). This allow to use the CP/M 3.0 batch conditional execution (see the CP/M 3 Programmer Guide par. 1.6.3) to run any wanted command or program based on the status of the IOS AUTOEXEC flag.

    I've prepared an example using an other CP/M 3.0 feature, the "PROFILE.SUB" batch that is automatically executed at cold boot (if it exists). To activate it (in the drive A:) rename the file PROFILE.SU as PROFILE.SUB with the command:


    Now you can see how it works setting the AUTOEXEC flag on or off with the IOS "Select boot mode or system parameters" menu.

  • QP/M 2.71 up and running (with IOS multi-boot management...)!

    Just4Fun09/17/2018 at 18:26 0 comments

    With the latest IOS revision and the corresponding new SD image (see the Files section) there is an interesting alternative to CP/M developed by MICROCode Consulting that supports also file timestamping, and it is 100% CP/M 2.2 "compatible".
    MICROCode Consulting has released the original installation files and all the documentation in their site with the "restricted usage" condition, that means free for non-commercial use and for personal use only.

    To enable timestamping (see upper screenshot) you need to install the optional RTC module.
    I suggest to read the QP/M documentation for the various commands (see the Downloads section in their site).


    The QP/M uses for the batch file the .QSB extension. So the AUTOEXEC file is now renamed AUTOEXEC.QSB. To enable the AUTOEXEC execution after the cold boot change the corresponding state to ON from the usual IOS boot selection menu. In the drive A: there is an example of AUTOEXEC.QSB file ready to run.


    Now the IOS has a new entry (8) in the boot menu to manage the OS multi-boot configuration:

    Each OS is associated with a set of virtual disks called "Disk Set", and changing the "Change Disk Set..." entry (8) will switch all the virtual disks of his "environment".

View all 12 project logs

Enjoy this project?



Tony Nicholson wrote 6 days ago point

This is a fantastic little board.  I'm now starting to tinker with things a bit and I'll be attempting to combine the CP/M 3 bios modules with Simeon Cran's ZPR3 replacement BDOS routines (obtainable from the Tesseract RCPM+ archives - volume 93 at ).

Before doing this I thought I'd attempt to reconstruct the supplied CPM3-128.SYS system from sources and I'm not having much success - in particular with all the choices when running GENCPM.  Would you be able to share the build procedure and corresponding GENCPM.DAT file?  Thanks.

  Are you sure? yes | no

HerveGZ wrote 07/12/2019 at 17:08 point

Dear All

Thanks again for this wonderfull Z80 board. And sorry to start a question as beginner, but

Is there a link to a startup guide global of this board? (something detailled explain)

Even I use it yet, I  have some problems to understand the I2C (protocol I know):
In examples there are out 1,opcode and out 1, value in general is so. But as I want to add my own I2C systems (from Grove or Seeed firms) I do not understand the relation between those out 0,xxx and out 1,yyy and the I2C address (Each item has a unique one ) of my own components I2C.

Can someone thanks  to enligh me on I2C how to mbasic can i drive any component I2C added please?



  Are you sure? yes | no

Just4Fun wrote 07/12/2019 at 17:31 point

Hi, opcodes are used to access to the virtual I/O devices. Read the comments in the .ino sketch about the virtual I/O engine to understand how they work (there are large comment parts in the code that are a sort of manual).

About  accessing your I2C device, this requires  changes in the FW. Some users in the FB users group have already done this to access an I2C LCD module.

You have to create new opcodes to access new I2C HW.

  Are you sure? yes | no

freefuel wrote 07/12/2019 at 07:46 point

I think the RTS and CTS labels are reversed on Serial header J2 on page 2 of 3 on the circuit diagram. the pins they are connected to on the AVR chip do not match. 

  Are you sure? yes | no

Just4Fun wrote 07/12/2019 at 17:34 point

RTS and CTS are connected to two GPIO. There is nothing to "match". More they are not currently supported.

  Are you sure? yes | no

freefuel wrote 07/12/2019 at 22:12 point

OK the documentation is confusing in it's current state.

  Are you sure? yes | no

freefuel wrote 07/12/2019 at 06:22 point

could PD2 pin 16 on the AVR be used to drive a latch for PC0, PC1 respectively pins 22 and 23 for the I2C interface to drive two additional SRAM address bits? I ask as I noted there is a pin compatible SRAM on digikey with a stated 4 Megabit/512K Byte capacity. (My other thought was to borrow a GPIO pin from the IO expander if you were only interested in warm booting between the banks.)   

  Are you sure? yes | no

Just4Fun wrote 07/12/2019 at 17:36 point

The bank switching HW is tailored to a 128KB SRAM.

  Are you sure? yes | no

freefuel wrote 07/12/2019 at 22:13 point

what harm would there be in wiring the currently unused GPIO to A17?

  Are you sure? yes | no

Adrian Wallaschek wrote 06/26/2019 at 00:50 point

Hi again, I have been hypnotizing the sheet for more than an hour now. Really? For the bootstrap the AVR serves as RAM? I guess the ce2 is used to shut up the SRAM, from then on, the AVR serves the reads. The bootstrap code works unrelated of the Z80s current PC: LD HL,something, then for each byte LD (HL),byte ; inc HL. There is no loop needed, just pump the bytes by repeating the last two. This will even work if the bootstrap target and the current PC overlap. Guys, I assume I guessed right +- some detail. This is really nice! From there on everything is IO and not memory. So my remaining question is: how do you terminate the data-provisioning on an IN-command? The WAIT triggers, the AVR puts the byte on the databus and resets the flipflop, the Z80 will read, but what makes the AVR then pull the D-bus on the AVR high? Is that hardcoded like several nop commands on the AVR and then pull high? assuming a nop is a single cycle and the relations of the frequencies are known. That easy?

Why am I asking: I try to do something like this with an Arduino-Mega, just with a bit more luxury. I thought to make the IN-command completely async, so the Arduino feeds a databus latch that is reset by a flipflop in reaction to IORQ going 1. But this turns the shield into a TTL-graveyard. If the nop-timing proves to be stable, it would easy my schema a lot.

For those interested: the Arduino Mega with its XMEM interface would offer real DMA. All I need now is a reliable IO-protocol.

Any confirmation to my guesses (I am too lazy to try to locate the right place in the code, to be honest ;-) shame on me) would be welcome.

  Are you sure? yes | no

Just4Fun wrote 07/12/2019 at 17:45 point

The Z80-AVR interaction schema uses a Wait-Bus_Hold sequence and was designed to be time-independent.

  Are you sure? yes | no

Adrian Wallaschek wrote 06/25/2019 at 23:22 point

I feel like a rookie. I do not understand the world anymore. First I was so stupid to look into the MBC schema instead of the MBC2. (Thanks to the one who pointed me to the right direction!) Now I believe I have the right schema, but I have no clue how this could work.

Why? For the MBC2 the only direct address-line connected to the AVR is A0. Now in order to boot the sketch would have to copy the bootstrap into the RAM before resetting the Z80, right? The MBC had more lines connected and that I understood, but with one address-line? Does the RAM have a boot-functionality so content can be clocked in just based on A0?  

So how does the bootstrap get into the RAM? Or is the sketch A040618 missing some connections? Honestly I believe my brain does. I do understand the wait logic and the GPIO is pretty straightforward, but how the bootstrap would work or how the bankswitching works escapes me ... completely. I feel old and tired.

Is there a kind of documentation with an explanation how these parts work? Or could anybody hint me where to find the related code?

Thanks in advance.

  Are you sure? yes | no

WestfW wrote 07/19/2019 at 07:57 point

The way that IO worked on the V1 board is that accesses to IO space would trigger the flipflop that would put the Z80 into "wait" state, essentially halting it.  Then the AVR would figure out what was going on, put stuff on or take stuff off of the bus, and un-flip the flipflop, allowing the Z80 instruction to continue.  Essentially, a really SLOW memory access, with the stuff that normally happens in memory or IO hardware implemented in AVR firmware instead.   I haven't looked at the V2 at all (I ad assumed it worked the same, until your message), but there's no reason that the same scheme couldn't work for Z80 memory accesses as well.  The V1 seems simpler to me - it's easier (?) to make the RAM access be full-speed, but it takes more pins.

  Are you sure? yes | no

Jim Bailey wrote 06/21/2019 at 07:02 point

Is it possible to build this system with a z80 rated for and running at 20mhz?

  Are you sure? yes | no

Just4Fun wrote 06/22/2019 at 17:25 point

The Z80 clock is generated by the Atmega32 and can't be greater than the half of the Atmega clock.

  Are you sure? yes | no

freefuel wrote 07/12/2019 at 06:06 point

so you could do 10MHz if you installed a 20MHz crystal on the AVR?

  Are you sure? yes | no

psmart wrote 06/18/2019 at 22:26 point


Please ignore below, the fuses were set incorrectly, CKSEL3:0 were set as 0001!!

  Are you sure? yes | no

psmart wrote 06/18/2019 at 21:48 point


Firstly, excellent project Just4Fun, a hark back to hard but fun computer times, nice professional work, thank-you.

Unfortunately Im having issues, I took to building two boards and both exhibit an identical issue so I was wondering if you have come across it. They are both programmed with the HEX file on your file list.

Basically, the IOS light blinks very slowly (every 2 seconds) and there is serial output (either after a plain reset or User+Reset) but not to a baud rate minicom can handle. The SD LED also flashes around the same time serial output occurs. Probing with a scope I noticed that the Crystal wasn't oscillating, I removed the crystal and caps and I still get exactly the same behaviour, it powers up, IOS light blinks slowly and serial output occurs but at a non-standard baud rate. There is also no activity on the Z80 side (ie. reset, D0-D7 are all idle).

First guess I would think the ATMEGA is using an internal oscillator ignoring the external crystal but without delving into the Sketch used to build the HEX file I can't be sure.

The only part Ive deviated from vs the schematic is a 1K resistor for R19 (should be 1K2) as I didn't have any in my parts box otherwise all is per the schematic.

Hence have you any ideas? Is there an issue with the HEX sketch?

Many thanks in advance for any help you can provide.

  Are you sure? yes | no

Jim Bailey wrote 06/16/2019 at 04:43 point

Built one and it worked on the first attempt.  I really love the flexible boot loader, whereby you can load and switch between OS's quickly.  Its fun to get to play with CP/M after all these years.

  Are you sure? yes | no

Linker3000 wrote 05/18/2019 at 20:58 point

Hi @Just4Fun,

Turbo pascal  compiled programs - even a 'Hello world' - exit to a CP/M warm boot. Is this expected as I don't experience this on other boards (RC2014 and a Grant Searle build).


  Are you sure? yes | no

Just4Fun wrote 05/19/2019 at 08:56 point

I think this is normal. What type of test have you done?  It is on CP/M 2.2 or 3?
 Could you add more details?

  Are you sure? yes | no

Linker3000 wrote 05/19/2019 at 10:05 point


Yes, this is on 2.2 with the following program (compiled to a .com):

  program helloworld;

    writeln ('Hello world');

I'm now wondering whether all systems do a CP/M warm start after running it, but only the MBC2 prints a message about it?

  Are you sure? yes | no

Just4Fun wrote 05/19/2019 at 15:35 point

The message on CP/M 2.2 warm boot is my own implementation...

  Are you sure? yes | no

WestfW wrote 07/18/2019 at 01:19 point

IIRC, a "WARM Boot" is how nearly ALL CP/M applications end.  Applications are competing with CP/M itself for RAM (usually <48k in a system), so when you load a program it overwrites the RAM that CP/M was using for the CLI and etc (everything except the code for the "services" that it provides to applications.)  When you exit the application, it has to re-load the CP/M command interpreter and such, which is what they call "warm boot."

  Are you sure? yes | no

Linker3000 wrote 05/17/2019 at 22:28 point

Hi Everyone, I've just updated my Z80 board port/LED writer utility so that it works with the GPIO ports on the Z80-MBC2 (if you've fitted the MCP23017 chip). You'll find the source code and a compiled (.com) version at the link below - upload to the Z80-MBC2 using XMODEM. Check out porter.pas and porter .com at If you do hook LEDs up to the ports, don't forget the current limiting resistors!

  Are you sure? yes | no

Koset *️⃣ wrote 05/05/2019 at 14:19 point

Q: I booted for the first time (yay) and chose BASIC. What's the procedure to exit back to the boot menu? "system", "exit", "bye" yield a syntax error.

I used the ICSP method to burn the boot loader.

  Are you sure? yes | no

Just4Fun wrote 05/05/2019 at 15:36 point

To return to the system boot menu you need to push down both the User and Reset keys, then release only the Reset key holding the User key down, and when the menu appears (or the User led turns off) release the User key (see also the paragraph


in the Description)

  Are you sure? yes | no

Koset *️⃣ wrote 05/05/2019 at 15:38 point

Thanks very much!

  Are you sure? yes | no

jonas.o.gustavsson wrote 05/03/2019 at 11:06 point

Just built my first Z80-MBC2! Actually it is my first "homebuilt" computer.. I found a couple of Z80 CPUs inside some roadside junk a couple of years back. This is really a great project, my hats off to its creator and everyone that has contributed!

  Are you sure? yes | no

Paul Bristow wrote 04/17/2019 at 18:06 point

I just assembled my kit from Mc John  Worked first time.  Excellent work.  Thank you everyone!  Now I'm battling cpm tools on MacOS Mojave to try to transfer a few things across.  It feels very early 80s. :-)

  Are you sure? yes | no

Frank N. Stein wrote 04/04/2019 at 19:29 point


your "LADDER" is really nice! - I found only V1.10 on the web and have problems to configure it. :-(

Where did you get your V1.30? - and how did you configure it??? Did you defined "Digital VT100" manually?

  Are you sure? yes | no

Just4Fun wrote 04/05/2019 at 10:44 point


Ladder 1.30 wortks "out the box"...

  Are you sure? yes | no

Frank N. Stein wrote 04/05/2019 at 19:36 point

Thanks for your link! - It is really called "ladder" in this ZIP-file? I can't find it... :-(

  Are you sure? yes | no

villaromba wrote 04/06/2019 at 15:16 point

Ladder, along with many other games is in the packages folder ( games.pkg). You need to use the instructions at if you haven't used depkg before.

  Are you sure? yes | no

Just4Fun wrote 04/08/2019 at 09:26 point

Exactly... :)

  Are you sure? yes | no

Frank N. Stein wrote 04/10/2019 at 17:27 point

Thanks! I didn't know DEPKG yet...

Is there actually a way to open these packages under Windows to look inside?

  Are you sure? yes | no

villaromba wrote 04/10/2019 at 20:35 point

Not so sure you can under windows but it's not difficult in CP/M :-

Although you can use xmodem to transfer a single file to your CPM machine, it is
a time consuming task to transfer software collections with large numbers of files.

Step 1: Using the "Binary to CPM Package" utility, you can combine many files to a single file called a package.  (games already packaged)

Step 2: Use xmodem to transfer the package & into CPM.

Step 3: Use to extract the original files.

Example:  depkg games.pkg

  Are you sure? yes | no

Frank N. Stein wrote 04/14/2019 at 16:33 point

@villaromba: Thanks for your detailed explanation - that works!

  Are you sure? yes | no

Frank N. Stein wrote 03/12/2019 at 08:24 point


Many, many thanks for the X-Modem implementation!!! Can you maybe post the matching Arduino HEX file? - that would surely be easier than rebuilding the whole Arduino IDE...


  Are you sure? yes | no

Just4Fun wrote 03/12/2019 at 14:21 point

Ok, I'll upload the .hex executable (version with the bootloader included) this evening...

  Are you sure? yes | no

Just4Fun wrote 03/12/2019 at 16:50 point


  Are you sure? yes | no

Frank N. Stein wrote 03/12/2019 at 20:19 point

FANTASTIC! Xmodem works like a charm! Really super! This is a great enhancement!!! Thank you very much!


I have problems with "GPELED.BAS", "RTC.BAS" and "USERLED.BAS" - it seems that all programs don't work anymore?!?

  Are you sure? yes | no

Just4Fun wrote 03/13/2019 at 18:05 point

Just tested now... They works now only with QP/M 2.71 that I left untouched and uses the old serial I/O mode.... hmmm...
I think to have an idea of the problem, and it should affect only "slow" interpreted programs (not the compiled one...)...
Further analysis is required...

  Are you sure? yes | no

Just4Fun wrote 03/14/2019 at 07:35 point

I think to have found the cause... now thinking to a possible solution...

  Are you sure? yes | no

Frank N. Stein wrote 03/25/2019 at 12:10 point

Your "" works very well (I tested Xmodem, "RTC.BAS", "USERLED.BAS" and my own programs on CP/M 3 - it seems that everything is now working properly)! THANKS!

  Are you sure? yes | no

asorc wrote 03/04/2019 at 18:52 point

First time It started I selected basic... Then, It appeared memory top? message, and since then, when I press reset, It says cold or warm start? If I select cold, It becomes crazy, if I select warm, It says ok. I am confused.

  Are you sure? yes | no

Just4Fun wrote 03/04/2019 at 19:23 point

You must press "Return key" at "Memory top?" and then select cold...

  Are you sure? yes | no

asorc wrote 03/04/2019 at 15:44 point

Is It needed a vt 100 terminal to run the z80-mbc2? Or any serial monitor works the same? 

  Are you sure? yes | no

Just4Fun wrote 03/04/2019 at 15:52 point

You can use any serial monitor. Some programs (video editors...) require a defined kind of monitor to work properly (generally they have a sort of config). Try and see...

  Are you sure? yes | no

asorc wrote 03/04/2019 at 18:45 point

Ok. Well... Something happened. I changed the baud option of the serial monitor of arduino ide, and It works for 9600 baud. Now, what's the different between cold and warm start? And What does "memory top?" means?

  Are you sure? yes | no

georgedb wrote 02/15/2019 at 11:07 point

Sorry, one more: can a 1N5819 be used instead of the 1N5817? When I look here [], I see slightly different parameters, and possibly the most important, slightly different forward voltages...

  Are you sure? yes | no

Just4Fun wrote 02/15/2019 at 12:20 point

I think yes...

  Are you sure? yes | no

georgedb wrote 02/15/2019 at 14:08 point

Will give it a try once I have received the components I don't have, and will report here.

  Are you sure? yes | no

Similar Projects

Does this project spark your interest?

Become a member to follow this project and never miss any updates