Close

ili 9341 lcd works at 5v now. but i'm not 100% sure why. to be continued. ordered 1 more

A project log for spi write up to 64 colors single instruction!

amg8833 equivilent sensor thermal cam is a perfect example of how to write faster with spi lcd displays. 128x128 sample fast on Arduino.

jamesdanielvjamesdanielv 10/12/2018 at 02:450 Comments

here is the display working at 5v, i'm not sure why it now works. i gave up on the resistor divider and re-soldered the connections i cut yesterday. soldering was a pain until i lifted up the lcd, and pulled up the flex, which was glued to pcb. i checked resistance of small wires i added and wire across the cut traces. although thin adds less than a 0.5ohm resistance. i checked the resistance in between between the pads and it was still high, continuity was zero .i checked resistance between gnd and wire trace assuming maybe the flux had created a resistor circuit. nope. so far the only thing that makes sense is folding back the flex cable from board. i checked glue as well, it does not conduct. i bought another display and will do two things when i get it, i will bed the flex board to release it from pcb, and if that does not work i will clean solder tip and heat up pcb to see if it breaks down to form a resistive area. then lastly i will apply flux. it is a mystery to me. ill post a how to video when i figure out why it did not work, and why it does now. i know i had wiring correctly because it did work with led used to lower voltage to 3v logic levels.  when i hooked up display  after fixing it from the cut traces and pulled back lcd flex, i tried testing pins individually to see if any would work at 5v ttl of Arduino. one by one they all worked, i thought weird, so i wired it without breadboard. it still worked. thought maybe 5v was plugged into 3v. nope it was to 5v.


Discussions