Close

Revision 0 PCB - Possibly on its way!

A project log for Yet Another m68k Homebrew

A full-featured Motorola 68k homebrew, this time with a 68010 running at 8MHz

Ross BamfordRoss Bamford 02/23/2020 at 18:303 Comments

For the past few weeks I've been waiting for the revision 0 PCBs, and I was going to wait until they arrived before posting a log detailing the build, but I'm aware it's been a while and thought I'd do a brief update.

I eventually decided to do a trial order with JLCPCB - despite my initial leaning toward OSHPark the price was ultimately the deciding factor - for prototype boards it just made sense to go with China where I could get five-off of the r0 board for a quarter of the price I'd pay for three from the US. I've heard (read) good things about JLCPCB so I decided to give them a go.

Unfortunately, my timing was (as usual) terrible, and the boards have been waiting for production for over a month - the recent Coronavirus outbreak has really hit hard and nothing's been in production. They did re-start production on two-layer boards a couple of weeks ago, but my four-layer has been waiting for things to settle down.

Naturally, I've been checking on the order frequently, and just now I've noticed that it seems to be progressing! Apparently it's now "waiting for carrier to pick up", so fingers crossed it is actually produced and will be here soon! I'll obviously update as soon as I know more.

In other news, I've started looking toward a revision 1 design, with some changes I wanted to make and some awesome suggestions from @henk.gooijen (see the discussion for details - they're worth a look!). Sadly, I've fallen foul of the latest Autodesk debacle, as I cancelled my EAGLE standard subscription (with my typical terrible timing again) just before they stopped offering it as a standalone subscription. Now, if I want EAGLE standard again, I have to pay for Fusion 360 as well! This means that the price is now roughly four times what I used to pay, because they bundle it with a piece of software I neither want nor need.

So, I've been looking around for an alternative. I'm prepared to put up with a learning curve,  and my needs are fairly modest:

I've had a look at KiCad in the past, and that seemed the most likely candidate, but I've not been able to get it working reliably on Catalina yet. This is something that I think is being worked on, so it will probably be the way I go - and to be honest, I've always felt I should be using it anyway, rather than the proprietary EAGLE...

In the meantime, if anyone has any suggestions for other software I might try, I'd love to hear about it!

Discussions

Ross Bamford wrote 02/24/2020 at 08:13 point

Thanks for the link Ken, 5.15 was the version I tried but it appears it's not yet notarised for Catalina and so wouldn't run. I'll try building it from source later today :) 

  Are you sure? yes | no

Ken Yap wrote 02/23/2020 at 22:54 point

I see this in the (old) bug tracker: https://bugs.launchpad.net/kicad/+bug/1834717

Have you tried the 5.1.5 release on Catalina?

  Are you sure? yes | no

Ross Bamford wrote 02/24/2020 at 20:59 point

To update, I disabled Gatekeeper and tried again, but KiCad crashed immediately on startup. I'm still looking into why and will probably hit the forum to see if anyone else is having the same issue, but in the meantime I installed it in a Linux VM so I can at least start learning how to use it :) 

  Are you sure? yes | no