Close

Display connector problem

A project log for VT100 simulator and 3D printed replica

Simulator for the VT100 hardware. Running inside Gardi's 3D model.

Lars BrinkhoffLars Brinkhoff 06/13/2021 at 16:106 Comments

It doesn't seem to fit.  The board layout seems slight different from other pictures I have seen.  Maybe it's a mismatch?

Discussions

Michael Gardi wrote 06/13/2021 at 17:14 point

Someone over on Instructables had the exact same problem:


Sadly, the Pimoroni box from Digi-Key had the wrong display driver board inside. The driver board for the 9.7" display is what they sent, but the connector is too small to insert the flex-wire connector from the 8" display. Arrrggghh! Just got off the phone with Digi-Key customer support and they now have to go check the other 15 in stock to see if this is a fluke or they have a bunch of non-matched driver boards. Guess I could get started printing the enclosure since that will take a while. :)

  Are you sure? yes | no

Lars Brinkhoff wrote 06/14/2021 at 06:18 point

Thanks for the information!

  Are you sure? yes | no

Lars Brinkhoff wrote 06/14/2021 at 06:28 point

By the way, I ordered mine from Mouser.  So maybe there's a mixup at Pimoroni.  I have emailed and tweeted them both.  (Sadly, customer service is sometimes better through Twitter than email.)

  Are you sure? yes | no

Lars Brinkhoff wrote 06/14/2021 at 11:30 point

Pimoroni is sending me new boards.

  Are you sure? yes | no

Michael Gardi wrote 06/14/2021 at 12:27 point

Great news on the new boards.

  Are you sure? yes | no

Michael Gardi wrote 06/13/2021 at 17:03 point

For sure that doesn’t look right.

  Are you sure? yes | no