A 4$, 4ICs, Z80 homemade computer on breadboard

No iron, no cry! Wire it to build a mini 4MHz Z80 64kB RAM system with Basic and Forth interpreters, CP/M 2.2, Assembler and C toolchains

Similar projects worth following
This is the Z80-MBC (Mobile Breadboard Computer), a mini 4MHz Z80 64kB RAM system with Basic and Forth interpreters, CP/M 2.2, Assembler and C toolchains. It can be easily expanded and it has an "Arduino heart" using an Atmega32A as an "universal" I/O emulator, and can be used and powered with a tablet or smartphone too...

During some surfing on Ebay I realized that with 4$ it is possible to buy enough ICs to build a complete Z80 system that can be done using a breadboard, and taste some flavor of retro computing.... So I did it and here it is the story!

Here is a video with the Z80-MBC in action:

and here with a smartphone (so it is explained the word "Mobile" in his name...) with a common OTG cable (the various test clips in this video were used for some measurements with a Logic Analyzer):


The needed ICs are:

  • Z80 CPU CMOS (Z84C00) 4Mhz or greater ($1.16)
  • Atmega32A ($1.70)
  • TC551001-70 (128kB RAM) ($1.10)
  • 74HC00 ($0.25)

Total cost: $4.21

The wires were taken from salvaged broken LAN cables, and the other components were salvaged from others unused breadboards.

The schematic is attached in the Files section. The MCU Atmega32A is used as universal I/O subsystem, as Eeprom, and as reset and 4MHz clock generator for the Z80 CPU.
Into the Atmega32A it is flashed an Arduino bootloader taken from here , and it is possible to use the Board Manager of the Arduino IDE for that.

Flash the Arduino bootloader at first (with the method you prefer), next you can start to build the whole thing!

Of course I used the Arduino IDE to develop the IOS (I/O Subsytem) that interacts with the Z80 bus and "virtualizes" the peripherals seen by the Z80 CPU.
As oscillator it is used the internal 8MHz Atmega32A oscillator, so no quartz is needed, and from this one is derived the 4MHz clock for the Z80 CPU (so the "Internal 8MHZ osc." bootloader variant must be chosen when flashing the bootloader from the Arduino IDE!).

The 74HC00 is mainly used as RS flipflop to stop the Z80 CPU during I/O operation, giving the needed time to the Atmega32A to interact with the Z80 bus.
The 128kB RAM TC551001 is used only for half (64kB) because the Z80 address space is only 64kB (I've chosen this IC for the low cost).
Note that only the CMOS version of the Z80 CPU can be used here. This because only CMOS version, under given condition that are respected in this schematic, has logical levels compatibles with Atmega32A and 74HC00.


You can use any Z80 CMOS speed grade, because the lowest is 4MHz.
The Atmega32A can be substituted with an Atmega16A, I've chosen the first one just to have enough space for future upgrades.
The 74HC00 can be substituted with a 74HCT00 if you already have one.
The RAM chip TC551001-70 can be substituted with any suitable 64kB RAM (do not use < 64kB RAM).
The USER led (D5 in the schematic) MUST be blue or white just to be sure that V(forward) is >= 3V.

Here is a video that shows a simple basic program that interacts with the "USER led" and "USER key":

On the breadboard there are others status led: the HALT led turns on if an HALT instruction is been executed and the Z80 CPU is in a Halt state, the DMA led turns on during DMA operations when the Z80 bus is in Hi-Z, the IO_OP led turns on when the Z80 CPU is accessing a I/O virtual device "emulated" by the Atmega32A (as the serial port), the LED_D0 led is the classical "Arduino" led (that one connected to D13 pin on the Arduino Uno) that here is connected with the Arduino D0 pin and is turned on normally as a power on indicator.

The serial port SERIAL-USB (see schematic) can be connected with a TTL-RS232 adapter, or with a serial-USB adapter.
I've used a serial-USB adapter that acts also as power source for the Z80-MBC, and has the DTR signal for the "autoreset" driven from the Arduino IDE. For a terminal that has a serial TTL port no adapter is needed.

In the schematic there is also the IOEXP port to expand the I/O capabilities, i.e. adding GPIO ports or a RTC for future expansions.


I've "ported" the Basic interpreter to the Z80-MBC using the sources provided in the great Grant Searle site , after the needed modification due the...

Read more »


Sources for CPM 2.2 and the BIOS

Zip Archive - 39.67 kB - 04/21/2017 at 15:29


CP/M 2.2 dual disk system images

Zip Archive - 184.12 kB - 04/21/2017 at 15:29


CP/M 2.2 single disk system image

Zip Archive - 101.05 kB - 04/21/2017 at 15:28


iDisk - S250317.c

iDisk source

x-csrc - 18.29 kB - 04/21/2017 at 15:28


iDisk - S250317.hex

The ready to use iDisk executable (.hex format)

x-hex - 17.68 kB - 04/21/2017 at 15:27



The sketch for the Atmega32A (New release. Adds the CP/M 2.2 Loader).

x-arduino - 153.30 kB - 04/21/2017 at 15:25


ViDiT - S090417.c

Test program for the Virtual Disk Module

C Source File - 9.53 kB - 04/18/2017 at 14:10



Virtual Disk Module schematic

Adobe Portable Document Format - 22.98 kB - 04/13/2017 at 19:29

Preview Download

Two SDCC demo programs.

Zip Archive - 1.25 kB - 02/09/2017 at 21:11


Two .BAT files for the SDDC toolchain.

Zip Archive - 1.01 kB - 02/09/2017 at 21:10


View all 23 files

  • CP/M 2.2, iDisk and a new IOS

    Just4Fun5 days ago 1 comment

      CP/M 2.2 quick set up guide

      The set up is very simple. I've done an utility (iDisk) to simplify all the needed operations. Of course the Virtual Disk Module must be present, but you can have also only a "single disk" installed (but I recommend the original dual disk configuration), meaning that only U1 (see the A110417.pdf schematic) is populated.
      The Assembler automated toolchain must be already set up.

      Here all the steps:

      1. Update the IOS using the new file S221116_R130417_Z80.ino in the File section;
      2. Reboot the Z80-MBC and select the iLoad boot mode (if not already selected);
      3. From the File section download the file "iDisk - S250317.hex" and copy it into your PC in the directory used for the Assembler automated toolchain . (Do not use the source file "iDisk - S250317.c" because it requires a special compiling option);
      4. From the File section download the file "" and unzip it (for a single disk configuration download the file ""). Each disk image is divided into four .hex files called "segment" (32kB each) that are named accordingly (e.g. D0XXX_SEG1.hex means the segment 1 of disk 0);
      5. Upload the file "iDisk - S250317.hex" to the Z80-MBC using the Dos batch L.BAT (see Assembler automated toolchain) with the command:
        L "iDisk - S250317.hex"
      6. When iDisk waits for the input stream:
        from the Tera Term menu select "File" -> "Send file..." and choice one of the unzipped .hex file from (or for a single disk configuration). After the upload iDisk will show a summary:
        at this point press W to proceed and confirm your choice.
        You don't have to follow any order in the "segments" upload sequence, iDisk will know how to do. To know before each upload what "segments" have been already written into the disks just see the "Disk segment write status":
        in the photo the segments 0, 1 and 3 of Disk 1 have been already successfully written, so you can choose any of the remaining;
      7. Repeat step 6 for all the eight (or four for the single disk pack) "segment" files;
      8. Press the Reset button on the Z80-MBC and enter into the boot selection menu:
        select 4 for the CP/M loader (and select the disk light ON if not already done, to have an idea of the behavior).

      All done!

      NOTE: if you experience errors during the serial upload increase the delay after each line from the Tera Term menu (Setup -> Serial port -> Transmit delay -> msec/line). In my VM I set up a 90ms delay. This is due because Arduino serial port doesn't have any handshaking.

      Disk speed

      The Virtual Disk Module is based on simple EEPROMs using a 200KHz I2C serial bus. Of course do not expect the same speed of an hard disk with a DMA controller!
      The speed probably is like using the floppy drive of those days...

      Single disk configuration

      You can have also only a "single disk" installed (but I recommend the original dual disk configuration), meaning that only U1 (see the A110417.pdf schematic) is populated.

      In this case you have about 120kB free, because the first two tracks of Disk 0 are reserved for the system image (Disk 1 doesn't have the system image, so all the 32 tracks are used for the file system).

      Because the BIOS is the same and is configured for a dual disk system, if you try to select the "B:" drive you'll get a "BAD SECTOR" error.

      Disk pack contents

      In the disk 0 image there are the various external CP/M commands, the Basic interpreter, the CP/M Assembler and the Macro Assembler.
      I've added also D, an alternative DIR command, and PEG, a bin to hex converter (and vice-versa) to exchange files:

      In the disk 1 image there is the complete Turbo Pascal compiler v3.01A with a sample program (SA.PAS):

      In the "single disk pack" the CP/M Assembler and the Macro Assembler are missing, and the Turbo...

    Read more »

  • Virtual Disk Module, a new IOS and ViDiT

    Just4Fun04/13/2017 at 19:37 3 comments

    It's time for a new "module", the Virtual Disk Module! In the photo is that one on the right, near the previous GPIO module.

    In the File section is possible see the simple schematic A110417.pdf with two I2C EEPROM 24LC1025.

    With this module it is possible to emulate two disks of 128kB each (probably like the floppy disk drives of those years).

    Each disk is divided into 32 tracks of 32 sectors. Each sector is 128 bytes long.

    Of course to manage this new HW there is a new release of IOS. The new file S221116_R180217_Z80.ino is in the File section.

    This new IOS checks if the module is present and prints a message if found:

    There is also a new item in the boot selection menu if the virtual disk is found, to use the User led as a disk activity led:

    I suggest to activate this option to have an idea of the behavior.


    In the File section I've added a simple test program (file "ViDiT - S090417.c") to check the virtual disk. Of course you need to compile it with the C "toolchain":

    About I2C speed

    With this IOS the I2C speed is 200KHz. Note that if you are using a 16MHz external quartz to clock the Atmega32 the I2C speed will be 400kHz. In this case I suggest to lower the two 4k7 pull-up resistors (on SDA and SCL signals) to about 2k2.

    The next Log will bring the CP/M 2.2 up and running...

  • Forth language, new multi-boot selection and a new name

    Just4Fun02/17/2017 at 21:33 4 comments


    Thanks to Bill Westfield now we have a new language for the Z80-MBC, the fig-FORTH v1.3 (here the link to the Bill GitHub repository with the source he adapted for the TASM assembler with the needed modifications for the Z80-MBC).

    The acronym "fig" stands for "Forth Interest Group", that was a world-wide non-profit organization (now dissolved) for the promotion of the Forth computer language.
    I've just started to play with this thing, and I must say that it is not the most friendly language I've seen... anyway it is an interesting different approach.

    To enable Forth just upload the new IOS release S221116_R120217_Z80.ino in the Files section, and select the Forth language from the new multi-boot menu (see next paragraph).

    Here it is a "blink" demo program:

    ( ****************************
    ( Blink test - Forth - Z80-MBC
    ( ****************************
    : ledon 1 0 P! ;
    : ledoff 0 0 P! ;
    : delay 4000 0 DO NOOP LOOP ;
    : blink CR ." Blinking..." CR BEGIN ledon delay ledoff delay 0 UNTIL ;

    To execute give the command "blink":

    If you are using Tera Term to send a text file to load a forth source, remember to set up a delay of 1ms for each character (serial port managed by the Arduino bootlader doesn't have any handshaking, so for now this is required to handle the serial stream without errors when sending a text file using a terminal emulator):

    New multi-boot selection

    Now pressing the User key after a reset brings to a new menu to chose the preferred boot mode. During this phase the LED-D0 will blink until you choose the boot mode:

    New name

    As you can see from the previous photos, from this release the MBC acronym changes to "Multi Boot Computer"...

  • An automated C language toolchain

    Just4Fun02/09/2017 at 21:26 0 comments

    Here how set up a toolchain to program the Z80-MBC using the C language. It is based on SDDC (Small Device C Compiler) and uses the same "process" of the previous Assembler toolchain.
    In the following it is assumed the the Assembler toolchain is already set up in a Windows host as described in in the Log: New iLoad boot mode and an automated Assembler toolchain.
    So only the SDDC relevant part is explained here.

    Here it is a short video with the toolchain in action:

    What you need to do:

    1. Create a working directory (or use the previous one) where to store the C sources and the two batch files (C.BAT and L.BAT) in the file from the File section (if you are using the same assembler working directory overwrite the previous L.BAT);
    2. With a text editor search the line:
      "C:\Program Files\teraterm\ttermpro.exe" /c=3 /BAUD=9600 /w="Z80-MBC Terminal" /m=LoadZ80.ttl
      inside C.BAT and L.BAT and verify that both the path and the COM number (/c=3 means COM3) meet your system;
    3. Download and install SDDC from here;
    4. Download the file S030217_crt0.s from the Files section in the working directory;
    5. Open the DOS command line and give the command: "sdasz80 -o S030217_crt0.s".
      Then rename the generated S030217_crt0.rel as crt0.rel. Copy it in the SDDC directory "C:\Program Files\SDCC\lib\z80" (may be a bit different in your system) overwriting the old one.

    All done!

    As usual close Tera Term before every new upload.

    To check if it is all ok, download from the File section the file and unzip it in the working directory.
    From the DOS command line give the command: "C Blink.c" to check if all the toolchain works as in the video.
    Try also the other demo ANSItest.c (taken from here) to check the ANSI capabilities of a different terminal emulator or a physical terminal:

    About SDDC

    I'm pretty new to SDDC. The SDDC documentation is 8051 "focused", so the given examples can be misleading if used with an other processor in mind.
    When "porting" SDDC to a target HW, there are 3 things to prepare:

    • customize the crt0.rel file that contains the initialization code for the target system;
    • add to the library the function putchar(char c) to send output to the console;
    • add to the library the function getchar() to read from the keyboard.

    I found the documentation quite missing about how to modify for a custom system.
    In particular in the provided crt0.s example there isn't a needed global declaration of three variables (l__INITIALIZER, s__INITIALIZED and s__INITIALIZER). Without this declaration the code will not compile.
    And to make this customization you need to know how the provided assembler works, but the assembler manual is not provided. So you must find it googling...
    If you are used to the Arduino IDE, read carefully the SDDC manual. This C compiler is a lot more "rude" about types and syntax... (as C standard is...).

    Last minute update

    Just found the assembler and linker documentation here!

  • Two layers PCB!

    Just4Fun02/06/2017 at 20:44 0 comments

    Thanks to Bill Westfield now we have a beautiful ready to made PCB!

    I've uploaded in the Files section all the Eagle files (schematic + PCB) zipped as
    There are two versions, the first one with some little bugs and a second one with the needed corrections (see the "readme" file inside the zip for the explanations).

    In any case I suggest to check at the Bill GitHub repository here for any update/information before sending it to a service (so you are sure to use the last updated version...).

  • New iLoad boot mode and an automated Assembler toolchain

    Just4Fun01/31/2017 at 20:36 4 comments

      This new IOS release (S221116_R230117_Z80.ino in the Files section) brings a new dual-boot mode. Now it's possible choose if boot with the usual Basic or use the new iLoad boot mode.
      iLoad (S260117.asm in the Files section) is an Intel-Hex bootloader that allows to load from the serial port a binary program using the Intel-Hex format, and execute it. I've used a large part of the source from this site.

      To select a boot mode just push the Z80-MBC Reset button and immediately after push the User button at least until the User led turns off.
      The selection works as a toggle switch, and is stored in the EEPROM.
      Here it is a video that shows how to switch:

      Using the iLoad boot mode it's possible to automate all the process from the source to the execution in the target.
      This video shows an automatic Assembler toolchain; only one command from the source assembler to the execution on the target (the source file BlinkDemo.asm used in the video is in the File section):


      What you need to do:

      1. Set up a Windows host or a VM (Virtual Machine). I've used a Windows XP SP3 VM onto a linux host;
      2. Load the Windows driver for your serial-USB adapter. Remember that your dongle *must* have the DTR signal;
      3. Create a working directory where to store the assembler sources, the assembler program and the two batch files (A.BAT and L.BAT) in the file (see the File section). With a text editor search the line:
        "C:\Program Files\teraterm\ttermpro.exe" /c=3 /BAUD=9600 /w="Z80-MBC Terminal" /m=LoadZ80.ttl
        inside A.BAT and L.BAT and verify that both the path and the COM number (/c=3 means COM3) meet your system;
      4. Download and copy in the previous directory the TASM v3.2 assembler from here. The on-line manual is here;
      5. Download and install the "Tera Term" terminal emulation from here;
      6. Set up Tera Term. From the Tera Term "Setup" menu select "Serial port..." and configure the parameters for your COM<n> connection to your serial-USB adapter. Set 9600 Baud, 8N1, Flow control none, Transmit delay 40ms/line. Save configuration with "Save setup..." from the "Setup" menu;
      7. Copy the file LoadZ80.ttl (see Files section) in the "Tera Term" installation directory, where it is installed the main file ttermpro.exe (for a standard installation for an English Windows version should be "C:\Program Files\teraterm");
      8. Open the file LoadZ80.ttl with a text editor and go to line 10. Edit the "setdir" parameter to meet your working directory path and name created at point 3. on your system, and save the file;
      9. Open the DOS command line and go in the working directory (using the CD dos command), attach the serial-USB dongle to the Z80-MBC and for a VM "connect" the dongle to the emulated usb of your VM. All done!

      Now it's time to check if it is all ok. From the DOS command line give the command: "A blinkdemo.asm" to check if all the toolchain works as in the video. To load the last compiled program give the command "L" without parameters. To load a specific intel-hex file give the command "L <filename.hex>".

      Close Tera Term before every new upload.

      iLoad behavior

      Please remember that iLoad will take the first address of the intel-hex stream as the starting address of the program, and after the loading will jump to it.
      iLoad will check the hex stream for errors, and protects itself if "someone" try to load a program (or a part) over it ("illegal address" error).

  • GPIO Expansion Module

    Just4Fun01/22/2017 at 13:50 2 comments

    This is the first add-on module for the Z80-MBC. It is a 16x GPIOs expansion module based on a MCP23017 IC, and can be easily connected to the Z80-MBC using the IOEXP connector (based on a I2C serial interface), of course on a breadboard...

    In the Files section I've added the schematic (A080117.pdf) and all the KiCad4 files (A080117
    There is also a new release of the IOS (S221116_R200117_Z80.ino) that takes care of it. During the boot phase, if the GPIO expansion module is found, a specific text is displayed:

    No configuration is needed, just plug it.

    Here is a short demo video:

    Each GPIO can be configured as input or output, and for each single input it is possible activate a 100K pull-up resistor. Of course this can be done from the Basic language, using new "virtual" I/O addresses as a language extension (if the module is not present, these I/O addresses are simply ignored):

    New WRITE I/O addresses:

              // GPIOA write (GPIO Expansion Module):
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    GPIOA value (see MCP32017 datasheet)
              // GPIOB write (GPIO Expansion Module):    
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    GPIOB value (see MCP32017 datasheet)
              // IODIRA write (GPIO Expansion Module):
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    IODIRA value (see MCP32017 datasheet)
              // IODIRB write (GPIO Expansion Module):
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    IODIRB value (see MCP32017 datasheet)
              // GPPUA write (GPIO Expansion Module):
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    GPPUA value (see MCP32017 datasheet)
              // GPPUB write (GPIO Exp. Mod. ):
              //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
              //                            ---------------------------------------------------------
              //                             D7 D6 D5 D4 D3 D2 D1 D0    GPPUB value (see MCP32017 datasheet)

    New READ I/O addresses:

                // GPIOA read (GPIO Expansion Module):
                //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
                //                            ---------------------------------------------------------
                //                             D7 D6 D5 D4 D3 D2 D1 D0    GPIOA value (see MCP32017 datasheet)
                // NOTE: a value 0x00 is forced if the GPIO Expansion Module is not present
                // GPIOB read (GPIO Expansion Module):
                //                I/O DATA:    D7 D6 D5 D4 D3 D2 D1 D0
                //                            ---------------------------------------------------------
                //                             D7 D6 D5 D4 D3 D2 D1 D0    GPIOB value (see MCP32017 datasheet)
                // NOTE: a value 0x00 is forced if the GPIO Expansion Module is not present

    And here is the Basic program used in the video (the HW wiring is shown in the comments):

    1 REM * * * GPIO EXPANSION MODULE (A080117) DEMO  * * *
    2 REM
    3 REM (USER Key -> slow led, GPIO-A(9) Key -> fast led)
    4 REM --------------------------------------------------
    5 REM Demo HW wiring (see A080117 schematic):
    6 REM
    7 REM   GPIO-B
    8 REM    (J3)
    9 REM   +----+   LED
    10 REM  | 2  |--->|---+
    11 REM  | 3  |--->|---+      RESISTOR
    12 REM  | 4  |--->|---+        680
    13 REM  | 5  |--->|---+-------/\/\/-----o GND
    14 REM  | 6  |--->|---+
    15 REM  | 7  |--->|---+
    16 REM  | 8  |--->|---+
    17 REM  | 9  |--->|---+
    18 REM  +----+        |
    19 REM                |
    20 REM                |
    21 REM  GPIO-A        |
    22 REM   (J4)         |
    23 REM  +----+   LED  |
    24 REM  | 2  |--->|---+
    25 REM  | 3  |--->|---+
    26 REM  | 4  |x 
    27 REM  | 5  |x
    28 REM  | 6  |x
    29 REM  | 7  |x     PUSH BUTTON            RESISTOR
    30 REM  | 8  |x        ---                   1K
    31 REM  | 9  |---------o o------------------/\/\/-----o GND
    32 REM  +----+ 
    33 REM
    34 REM
    35 REM
    36 REM --------------------------------------------------
    37 REM
    38 REM Set MCP23017 GPIOB all pins as output (IODIRB=0x00)
    39 OUT 6, 0
    40 REM Set MCP23017 GPIOA 0-1 as output, others as input (IODIRA=0xFC)
    41 OUT 5, 252 
    42 REM Set MCP23017...
    Read more »

  • SOFTWARE INTERNALS: The boot process

    Just4Fun01/04/2017 at 14:35 0 comments

    Here is a description of the two phases boot process and the sources of the Loader and the uBIOS + Basic (as requested by some people).

    At power on, the Atmega32A uses a DMA access to SRAM to copy the loader in the upper memory address space.
    Because the loader is small, only a limited number of address lines are requested, saving some GPIOs for others tasks.

    When the Atmega32A completes the DMA loading phase (first phase), it releases the Z80 bus and resets the Z80 CPU that starts to execute the loader from SRAM starting at address $0000.

    Then the loader relocates itself at the bottom of the memory address space and it loads from the Atmega32A (this time used as a "virtual" sequential ROM in the I/O address space) the uBIOS + Basic image (second phase).

    After this second load phase it jumps to the starting address of the uBIOS + Basic image, and executes it.

    Inside the Arduino sketch you can see the two hex arrays. The smaller one is the Loader image, the bigger one is the uBIOS + Basic image.

    In the Files section I've added the Loader source (S091116.asm) I wrote from scratch, and the two files (uBIOS and Basic) I took from the Grant's site. I've modified the first one (the one I've called uBIOS) that contains the I/O routines due the different HW design. In particular I changed the I/O addresses, the init code made for the original ACIA and the code to menage the internal registers of the ACIA. I've changed also the code that manages the ACIA serial handshaking because not needed here (the serial is managed inside the Atmega32A by the Arduino bootloader "environment") . You can easily see any modification in the source (S121216.asm) because they are marked with the string "Z80-MBC:" in the comment.

    I left the Basic interpreter (basic.asm) untouched (for now, until I need some custom commands...).

View all 8 project logs

Enjoy this project?



WestfW wrote 4 days ago point

I've added Gerbers for the V2 (untested) version of the PCB; something I should have done a long time ago...

  Are you sure? yes | no

Cyril V. wrote 3 days ago point

Thank you, this is great!

  Are you sure? yes | no

villaromba wrote 6 days ago point

Virtual Disk - works great & exactly as described !! Thank you ...  Is/will it be possible to save BASIC & Forth progs to the virtual disk, now or in the future? Looking forward to CP/M post

  Are you sure? yes | no

Just4Fun wrote 5 days ago point

The current BASIC & Forth interpreters can't use the virtual disk.

Inside the CP/M "disk pack" there will be the Basic-80 interpreter that is an upgrade of that one used before (and 100% compatible), with the Load and Save function of course, and a lot more. So there will not be any reason to use the "stand-alone" version anymore.

About the fig-Forth 1.3 it has inside a sort of disk system, but:

* is totally not compatible with CP/M file system;

* is incompatible with the Z80-MBC Virtual Disk (until modify the source).

So it probably will be better use a CP/M forth compiler...

  Are you sure? yes | no

legacy wrote 2 days ago point

So, what's the point of this project? At the beginning it was interesting, but what about now? Using CP/M? On real hw? Bah ... I have created a CLI emulator for CP/M, it works for linux and UNIX, and it's like applications (e.g. Microsoft Basic Compiler, etc) were native. Ten times better, faster, and comfortable than digging with a real z80 board.

  Are you sure? yes | no

villaromba wrote 04/08/2017 at 17:59 point

Oh WOW!! This looks really exciting .....can't wait !!!

  Are you sure? yes | no

Just4Fun wrote 04/08/2017 at 14:21 point

Stay tuned.... 

  Are you sure? yes | no

Yann Guidon / YGDES wrote 04/08/2017 at 21:09 point

congrats !!

  Are you sure? yes | no

Just4Fun wrote 4 days ago point


  Are you sure? yes | no

Steve wrote 03/22/2017 at 20:56 point

Yay, just got mine up and running.  I used an ATMEGA644 (happened to have one lying around). In case you're going to use this you need to change some registers to get the 8MHz clock setup right (see ) as follows:

// Initialize CLK @ 4MHz. Z80 clock_freq = (Atmega_clock) / (OCR2 + 1) = (Atmega_clock) / 2
  ASSR &= ~(1 << AS2);
  TCCR2B |= (1 << CS20);
  TCCR2B &= ~((1 << CS21) | (1 << CS22));
  TCCR2A |= (1 << WGM21);
  TCCR2A &= ~(1 << WGM20);
  TCCR2A |= (1 <<  COM2A0);
  TCCR2A &= ~(1 << COM2A1);
  OCR2A = 0;
  pinMode(CLK, OUTPUT);

Many thanks for a fab project !

  Are you sure? yes | no

Just4Fun wrote 04/08/2017 at 14:19 point


  Are you sure? yes | no

Paulo Alcobia wrote 03/04/2017 at 18:10 point

I have some spare PCBs to sell for 5 USD plus shipping, let me know if you need any.

  Are you sure? yes | no

WestfW wrote 03/05/2017 at 22:29 point

My design?   The "new" version?   Does it work?

  Are you sure? yes | no

Paulo Alcobia wrote 03/06/2017 at 14:05 point

Yes, your design, the one posted here, i had 10 built but I only need 2, and I still have 6, blue solder resistor

  Are you sure? yes | no

John wrote 03/22/2017 at 01:14 point

Hi Paulo, I just received the board you sent.  Thanks!

  Are you sure? yes | no

Cyril V. wrote 5 days ago point

Can you please provide the GERBER File that you used for this PCB (from WestfW latest Z80-4chip7 Eagle files)? - Thank you

  Are you sure? yes | no

Peabody1929 wrote 03/03/2017 at 17:48 point

I would really like to have a SD card interface to use with CP/M.  The SD card would replace the floppy discs in CP/M.  The problem is the Atmega32 does not have the SPI signals available to connect to the SD card.  "What if" we used another Arduino board as a  Disc Controller?  It would connect to the Atmega32 using I2C and to the SD card using SPI.  An Arduino Nano or Arduino Mini with a SD card interface could be a $5 CP/M disc subsystem.

  Are you sure? yes | no

Just4Fun wrote 03/07/2017 at 07:47 point

Yes, you can do it, writing your own I2C - SPI interface on the "slave" Arduino Nano and modifying the IOS as/if needed. Or, you can just wait... 

After the CP/M up and running on I2C EEPROMs, "probably" I'll make a new HW revision. This new HW revision "probably" will bring "some" enhancements, and "may be" that the SPI pins on the Atmega32 will be freed....

  Are you sure? yes | no

WestfW wrote 03/03/2017 at 07:52 point

I keep thinking "if only the Atmega32 has a few more pins, things would be easier."

Then I was wondering about those STM32f1xx-based "Maple Mini" clones ( ) ( Less than $5) - the summary claims 34 IO, but I'm not sure whether that's before or after you deduct the USB and "boot" pins and etc.  (hmm.  not 5V, though.)  OTOH it has USB built-in, and is supported by STM32duino...
Another interesting possibility is the Cypress CY8CKIT-049-42xx ($4, less likely to be available with "free shipping.") - I'm counting 38 io, with similar uncertainty.  It has USB/Serial included, and it has programmable digital logic blocks that might allow elimination of the 7400 (expensive chip that it is, right?), and it runs on 5V.

OTOH, it gets increasingly silly to use these as "IO/boot" controllers :-(  But maybe not...

  Are you sure? yes | no

Just4Fun wrote 03/03/2017 at 09:06 point

I know those STM32 "Maple Mini" clones quite well, as I've made my "own version"  (see here: but the 3.3V is annoying here...

The PSOC4 are very interesting... I've given a look to the PSOC 4200 datasheet. It seems that they can run at 5V too. Not sure if the "digital blocks" (UDBs) can be used without I/O limitations (I mean only to mix external input signals to the embedded peripherals). But they seem not to be easy to find parts... (I mean not so "easy" as Atmega and STM32 chips...), and they are a "little" complex too...

After all I thing that the best "option" can be to use an Atmega128A (you can find it at about 1$ or less). It has 128kB flash and a lot of pins.

Because it is a SMD component, I was thinking to make two new HW boards, one using only TH components and one (more advanced) using THs and SMDs.

I was also thinking about banked SRAM (512kB) to eventually try UNIX as OS (I've just ordered some cheap 512kB SRAMs)...

It is also possible to free "some" pins from the current design with a little HW optimization. This will be probably the next thing after having CP/M up and running on the current HW.

BTW: In the meantime I need to find the time to complete a low cost (about 5$) "demo" board to start playing with HDL languages using a MAX II CPLD and a STM32 as patterns generator... :-)

  Are you sure? yes | no

K.C. Lee wrote 03/03/2017 at 11:28 point

There are about 20 pins that are 5V tolerant on the STM32F103 that can talk to TTL just fine in both directions.  

>Unless otherwise specified, the parameters given in Table 35 are derived from tests performed under the conditions summarized in Table 9. All I/Os are CMOS and TTL compliant.

The CMOS Z80 and RAM I/O are at TTL threshold for input, so not even sure why 5V is a problem this time.  If you need more, it is a matter of buffering the rest of the I/O.

I think we have analyzed to death for crappy AVR 5V CMOS I/O previously.

  Are you sure? yes | no

Just4Fun wrote 03/07/2017 at 08:12 point

Yes... The STM32F103 have the "FT" pins... 

I currently have some STM32F103 "flavors" and some Atmega128A too, so probably it will be a "last minute" choice...

BTW: anyway the PSOC4 are "intriguing"...

  Are you sure? yes | no

asorc wrote 02/19/2017 at 22:45 point


Does the serial port accept keyboard? Could I use a TV with composite video connection as an screen? Or better, Is it possible to add a composite video connection to this computer?

Thanks, very, very, very nice project. Thanks for sharing it. Regards.

  Are you sure? yes | no

Just4Fun wrote 02/20/2017 at 08:01 point

Hi, for now is not possible. Only one serial communication is allowed (so you can use a serial-USB adapter for a PC terminal emulation or a serial-RS232 adapter for a "physical" asynchronous terminal as a VT100 or VT220 etc..).

But you can easily build your own asynchronous terminal and attach it to a video composite TV input and a PS/2 keyboard with just one Atmega328 and one 74HCT166 (for the video signal generation) and one Atmega88 (for the keyboard). See this project made by Grant Searle:

I also remember an other project around that uses SPI output for the video generation without the need of the 74HCT166 shift register (if I remember well)...

  Are you sure? yes | no

asorc wrote 03/03/2017 at 23:33 point

Just another thought has come to me, since I got a ZX spectrum 48 k. With this 4 ICs, could it be possible to make a ZX spectrum clone? Maybe it would be necessary to get a ROM chip with the sinclair basic in there, but for the rest, I wonder if it could be possible, with a PS/2 USB keyboard. It came to me because the ULA of ZX spectrum maybe is difficult to get today. I do not know... Just a thought to share. 

Thank you.

  Are you sure? yes | no

WestfW wrote 03/04/2017 at 03:58 point

Not really.  The ZX systems used a tightly coupled processor and video system, so that generating video would access memory (mostly) when the Z80 wasn't (refresh cycles?  I don't remember the exact details.)  Sneaky, and more or less requires "hardware" interaction.   Using the m32 as a general purpose IO device gives you a lot of flexibility, but it's also very slow.  A lot of the "clever" Z80 programming from the old days  involved interfacing to weird hardware as quickly as possible, which isn't really possible on this 4chip system - essentially, you're restricted to fiddling with "pure software" on the Z80 side.

  Are you sure? yes | no

WestfW wrote 02/12/2017 at 23:32 point

I found this similar project; fewer details, but it does look like they got CP/M running...

  Are you sure? yes | no

Just4Fun wrote 02/13/2017 at 07:32 point

Interesting... it seems the same approach...

I was curious to see how he managed the the t(hold) stuff on the Z80 bus, but there isn't any detail about it... :(

In any case there are some information...

  Are you sure? yes | no

WestfW wrote 02/12/2017 at 20:45 point
"I'd better use DosBox"

 Hmm.   The last time I tried to use DOSBox, it was excessively focused on running old games, which you'd think would be MUCH harder than running old command-line compilers.   I wonder how much work it would be to put together a more CLI-oriented DOSBox for the non-gaming retro-computing community, that would end up with a Wine-like interface "Dosbox tasm -80 figforth.asm"  (and I wonder how well the DOSBox source is documented...)

  Are you sure? yes | no

legacy wrote 03/05/2017 at 16:27 point

What's the problem with DosBox? You can -1- generate a script (dot bat) for the DOS compiler, -2- invoke DosBox, -3- force it to mount the local folder, so it will load the script and you will have the job done as you wish.  A CLI-oriented DOSXBox will only work for those DOS apps which use BIOS call for early stream in/out, and if they don't (e.g. the Sierra's CC and its CPP don't do it, since they require more advanced DOS calls)  would be complex to pass the input through the stdin, and to grab-out the output through stdout and stderr. More complex than emulating the virtual disk to pass the bat-script, more even more complex than emulating the video card to read what's wrong with the commissioned job.

BTW.  I have a super simple DosBox overlay (=git branch) in my repository. Compiled for my RISC Workstation. I have removed OpenGL, MIDI, SoundCard, Joystic, Sound, Soundblaster emulation, etc etc.

  Are you sure? yes | no

legacy wrote 03/05/2017 at 16:31 point

p.s. note that STDOUT and STDERR, they both *suck* a lot on Win32 Apps under Wine! Their output look drunks (do they drink too much Wine? I guess. It may be)

  Are you sure? yes | no

legacy wrote 03/05/2017 at 17:10 point

so, after removing everything (midi, sound, etc, including the annoying splash-screen), I have experimented a bit ….


moved here; however, Keep in mind that 

-1- SDL is still used, and still invoked by DOSBox when it's called, therefore you need to export the DISPLAY (X11 stuff)

-2- 'as11.exe' does neither directly accesses the video card, nor does DOS calls, so it's a common  console.putchar, which goes through bios system calls. And the trick actually works.

-3- I am not sure about the behavior of other DOS compilers. Those who pass through DOS calls.

  Are you sure? yes | no

WestfW wrote 03/05/2017 at 22:35 point

So what's your github id?
Consider generating a project here pointing there, for "Development tools oriented DosBox."  Or something?

  Are you sure? yes | no

legacy wrote 03/05/2017 at 22:47 point

I don't have a public repository, and don't need to modify DOSBox! As I have explained below you just need to create the launcher script, and passing through it


the redirection to STDOUT works ONLY if the dos-application uses something similar to the the following BIOS service 

mov $0x09, %%ah

int $0x21\n


see this topic, the bash script  is parked there.

  Are you sure? yes | no

WestfW wrote 03/05/2017 at 23:02 point

BTW: "int 21h" is the basic DOS system call API.  "BIOS" was the sub-dos SW interrupts like "int 12h" for low-level disk primitives (read/write sector, etc.)  In theory, you could have a DOS-compatible computer that used completely non-PC hardware. (in fact, I owned one: an HP150.)  It's the sort of thing that I meant that DOSBox spends too much effort on; replicating the BIOS and early hardware, so that DOS games can run (DOS itself had little to no graphics ability, no video awareness, and few "devices" other than CON and files.)  In theory, a "DOS emulator" would be a MUCH SIMPLER project, if it only did enough to support compilers...

  Are you sure? yes | no

legacy wrote 03/05/2017 at 23:24 point

SierraC is a command-line-compiler. It works under DOS-v6, it works under DOSBox, but it DOES NOT work with the above DOSBos trick. Don't ask my why. You can see the output on the emulated VGA screen but the file redirection fails since the output file is completely empty. Perhaps it doesn't use int $0x21\n and does strange things under the hood. Who knows?

  Are you sure? yes | no

legacy wrote 6 days ago point

I have created a CPM/Z80 wrapper for CPM/Z80 tools

Cube test $ zxcc /opt/z80-cpm/bin/
Copyright (C) 1984-87 HI-TECH SOFTWARE

Cube test $ ls
Cube test $ zxcc /opt/z80-cpm/bin/
Cube test $ ls

There is a full Z80 cpu emulation in software, plus a full wrapper between linux and CP/M

basically it works like DosBOX, but without any GUI.

  Are you sure? yes | no

villaromba wrote 02/11/2017 at 11:51 point

Thank you for updating SDCC guide, much clearer and at last I have ANSI.c working. Couldn't figure out the crt0 bit!! Looking forward to CP/M and Forth .............

  Are you sure? yes | no

WestfW wrote 02/11/2017 at 05:20 point

Whee!  fig-Forth 1.3 working!

I had to convert assemblers, and it took me a long time to figure out how TASM was treating some of the code differently than the original 8080 assembler; it was causing really mysterious problems!  Added

  Are you sure? yes | no

villaromba wrote 02/11/2017 at 12:24 point

Thank you - works brilliantly - need to get the Forth books out now!!

  Are you sure? yes | no

Just4Fun wrote 02/11/2017 at 13:43 point

Wow Great!!

It seems I've to learn an other language... :-) (for now I can only replicate your example...)

It is about 8KB, so it leaves inside an Atmega32 about 10KB for CP/M stuff. I think it should be enough...

So next days I'll do a new IOS release with Forth and, at this point, a more "sophisticated" multi boot management... (and it's time to change the MBC acronym...)

BTW: In the meanwhile "some" AT24C1024 are on the way... I've just realized that I've got only an AT24C32 :(

Thanks again!

  Are you sure? yes | no

Scott wrote 02/11/2017 at 20:29 point

It's too bad that TASM is so incompatible with the Z80 assemblers available for Linux. :( No easy way to run TASM under Linux unless I use DOSBOX or the like, which I do not wish to do.  I would consider re-spinning it as a Linux executable but I cannot find the source code for TASM, so it must not have been released.

I found a program in UBUNTU repository named "intel2gas", which is supposed to convert TASM to AT&T format for GCC's "gas" assembler.  Looking at GCC, there is a "Z80 target" but I was not able to configure GCC and MAKE the target toolchain without error.  

Does anyone have a conversion script to convert TASM to either Z80asm or Z80-asm?

Peace and blessings.

  Are you sure? yes | no

legacy wrote 02/11/2017 at 21:06 point

I have the same problem with HC11. AS11.exe is 10 years light far from being compatible with GAS11. What's wrong with dosbox? it works on linux, macOSX, freeBSD and UNIX, even on a not-x86 machine (e.g. my Apple PowerBook G3 laptop). So have fun with it. 

Converters just don't work, especially for MACROs!

  Are you sure? yes | no

Scott wrote 02/11/2017 at 21:17 point

Thanks for your input.

If DOSBOX was like WINE, then I would.  With WINE, I can run "wine avrasm.exe test.asm" and it runs the "avrasme.exe" file, which assembles "test.asm" and leaves the resulting file in the current directory; easy and clean.  With DOSBOX, I have to run a separate (Free)DOS "virtual machine" and if I have to do that, I might as well just run TASM under my WINDOWS virtual machine under Linux.  

I was looking for a "cleaner" way to assemble Z80 programs via Linux command line tools so I can use an automated make file.

Peace and blessings.

  Are you sure? yes | no

legacy wrote 02/11/2017 at 23:06 point

keep in mind that Wine doesn't work with DOS16 executables, and it's not stable with win95 applications. It requires win32 binaries.

With dosbox you can mount the current folder. Inside dosbox, type "mount c: ."

Or check your home, you should have ~/.dosbox/dosbox.conf. In case, you just need to append the following:

mount c: .


  Are you sure? yes | no

WestfW wrote 02/12/2017 at 03:24 point

I'm using Wine to run TASM on my mac.  Aside from various error messages from Wine itself (because I'm running an older MacOS, I guess), it seems to work fine.

  Are you sure? yes | no

Scott wrote 02/12/2017 at 04:49 point

Hi Bill:

Holy cow!  Being that TASM is a DOS program, I never thought to try TASM under WINE!  I just tried it and it seems to work.  Thanks for that update.  :)

BTW: PCB is up and running.  I added a jumper to "bank select" A16 on the RAM between "upper" and "lower" 64KB bank.  No free I/O pins on the AVR though. :(

Peace and blessings.

  Are you sure? yes | no

legacy wrote 02/12/2017 at 10:32 point

well, googling you can find three versions of asm11.exe, an assembler for HC11: { Dos16bit version, Win95 version (16bit, Windows-95 API), Win32 version (32bit, Windows-98/99 API) }
a) The win95-asm11.exe executable works great under a real Windows XP machine, but it sucks a lot under Wine, it **seems** to work but  it does not, sometimes it does't work as expected, you don't see the error messages, and the list file is not generated.  Annoying.
b) The Win32-asm11.exe executable (updated to 2016) works great on both Wine and XP platforms. It generates list files, and I can see error messages if I voluntary type a typo, but the author has improved the code so much that the macro-handling is not compatible with the legacy code. I don't want to waste my time converting || fixing sources, so I just can't use it. 
*) DosBox. can execute nor win95 neither win32 binaries, not directly, check out sources, if Wine catches a Dos16 binary it tries to launch DosBox, and execution goes through it. DosBox can also run dos32bit executables, such as games which needed a dos-exteneder, e.g. DukeNuken3D and Doom.
c) The Dos16-asm11.exe executable works great under OS/2 Warp3/dos16-mode, XP/dos16-mode, and DosBox!
~ ~ ~ ~ ~
My conclusion is: for the vintage software, those things written for dos-16bit (including Turbo Pascal, Turbo C, ASM11, SierraC, OrCad SDT), I'd better use DosBox!

  Are you sure? yes | no

WestfW wrote 02/12/2017 at 20:35 point

In retrospect, it's not clear whether "TASM32" is version 3.2, or whether it's a WIN32 version of the .EXE.

I agree that Forth is a very odd language.  The nice thing about it is that you can get pretty quickly to a place where you can string together relatively language-like interactive constructs like:

   1 setuserled delay10ms 0 setuserled

without having to write any keyword or expression parsing code.

  Are you sure? yes | no

Scott wrote 02/12/2017 at 21:45 point


I investigated the type of executable TASM is.  Here is what Linux reports for TASM 3.2:  TASM.EXE: PE32 executable (console) Intel 80386, for MS Windows

I also tried TASM 3.1, which wine does spawn a DOSBOX window but no object files are produced.  Linux also reports: TASM.EXE: MS-DOS executable, MZ for MS-DOS

Thanks for the clarification.

I don't have to try and convert to another assembler format.  I just need to figure out how to pass the PATH to TASM.EXE and it's tables while I am in another directory.

Peace and blessings.

  Are you sure? yes | no

Scott wrote 02/13/2017 at 06:32 point

I was able to get V3.2 of TASM to work from the Linux command line.  It ran fine with WINE but passing the location of the TASM tables was an issue until I found the the user manual online.  The invocation is:

TASMTABS=[path to TASM directory] ; wine [path to TASM directory]/TASM.EXE -80 -la -x -s BlinkDemo.asm 2>/dev/null

WINE tends to dump extraneous (and annoying) debug info to the error console, so the "2>/dev/null" prevents that and you are left with TASM's output.  I am running the newly released version 2.1 of WINE but it should run the same under V1.4 as well.

WestfW has a bash script for MacOS now, which I think he will post when he gets a chance.

Peace and blessings.

  Are you sure? yes | no

Peabody1929 wrote 02/08/2017 at 01:05 point

Would you share the method you used to create the labels on each of the ICs?


  Are you sure? yes | no

WestfW wrote 02/08/2017 at 06:13 point

I used EAGLE, which was pretty easy because I already had the text for pin names placed on the PCB at the appropriate spacing anyway.  I just copied that part of the silkscreen to a new "board" , used rectangles on the top, bottom, and via layers to provide the colored background, and duplicated it a bunch, used the "print-transparent-brd" ULP to get the black-on-faded-colors look, and printed on full-sheet laser labels...
The file is in the github repository:

(I really like using EAGLE as a general purpose drawing tool when I have technical diagrams to make that need to have specific dimensions.  And not many drawing programs will let you enter coordinates in polar notation, which is useful ...  more often than I would have thought!)

  Are you sure? yes | no

Scott wrote 02/11/2017 at 21:20 point

I have a post that illustrates the method I used under Linux.  I provide a base template file with many DIP packages already outlined.  All you do is add the text (on separate layers) using GIMP.  Here's the post: 

Peace and blessings.

  Are you sure? yes | no

Just4Fun wrote 02/05/2017 at 14:39 point

Rainy day... So starting to make first experiments with CP/M...

  Are you sure? yes | no

villaromba wrote 02/04/2017 at 10:43 point

Great work and thankyou, blinkdemo.asm working great, just needed to amend .BAT files to agree with my directories and COM port in case anyone not aware that it may not be the same as yours. Like you now need to learn SDCC and try out the ANSI test. etc Looking forward to next installments!!!

  Are you sure? yes | no

Just4Fun wrote 02/04/2017 at 16:50 point

Ops... I forgot to mention it in the "guide"... 

Just corrected... :-)

BTW: The SDCC documentation is quite missing about how to modify for a custom system... anyway "googling" a little I've sorted...

  Are you sure? yes | no

WestfW wrote 02/04/2017 at 07:32 point

PS: Working on Forth, which should fit in the m32 flash WITH the BASIC already there.
Z80 Forth is apparently in a relatively sorry state - the ones I've found use obscure assemblers and/or have CP/M dependencies.  But ...  Forth is one of the environments that really benefits from a "RAM-rich" hardware implementation.

  Are you sure? yes | no

Just4Fun wrote 02/04/2017 at 17:02 point

This sounds good! I haven't ever used Forth, but after a 5 minutes search it seems a good "environment" for an "embedded" system... I'm very curious...

So the Z80-MBC will became a "multi-boot" system: BASIC, FORTH, Intel-Hex loader for Assembler and C toolchains, and... may be a day... CP/M too... 

(I'm starting to think to rename it as "Z80 Multi Boot Computer"....)

Not too bad for a 4$ system... :-)

  Are you sure? yes | no

Scott wrote 02/05/2017 at 06:31 point

Keep in mind that the ATmega644 and ATmega1284 are pin-compatible with the ATmega32, thus the larger memory parts can be used if larger memory requirements are needed. I.e. multiple "ROM" images; BASIC, FORTH, etc. 

  Are you sure? yes | no

Just4Fun wrote 02/05/2017 at 14:57 point

Yes ... I have to have both somewhere ... still are a bit expensive ... I'm starting to think about an Atmega128A .. I can find it for less than $ 1 ... but for a new HW revision... may be one day... :-)

  Are you sure? yes | no

WestfW wrote 02/06/2017 at 06:17 point

I'd rather add a bit I2C EEPROM "Floppy Drive." A 1Mbit EEPROM is 128kBytes, which is pleasantly similar in capacity to some of those early "mini" (5.25inch) floppy disks, is pretty commonly available in DIP8...

  Are you sure? yes | no

Just4Fun wrote 02/06/2017 at 21:02 point

Mmm... I was just starting to think what to use as "virtual" floppy.. The first thing was a SD as "the definitive" mass storage, but it brings some complexity in the current design... After all an I2C EEPROM might be a good tradeoff to start to play with CP/M... 

  Are you sure? yes | no

Scott wrote 02/06/2017 at 22:48 point

I toyed with the idea of using an off-chip I2C EEPROM for my Z80 SBC project but decided that using the SD card interface, although a bit more complex, does allow me the ability to "load" "virtual floppy disks" via my laptop.  Using an EEPROM as a "virtual floppy disk" would need a user interface written to transfer files back and forth from the laptop. 

WestfW, when you get a chance, check your private messages.

Peace and blessings,


  Are you sure? yes | no

Just4Fun wrote 02/07/2017 at 07:56 point

Yes...  this is the "odd" thing of using an EEPROM...
Anyway I think that it would be possible  to use both... I mean first one or
two EEPROMs as an easy first approach (as A: and B:), and then
eventually a SD as a virtual HD (as C:). This remind me "something"....

  Are you sure? yes | no

Scott wrote 02/07/2017 at 08:22 point

I agree; step by step.  EEPROM is easy to implement but limiting in accessibility.   Use as "proof of concept" then perhaps SDcard, which is more accessible but has a steeper learning curve to implement.  Always baby steps when creating, yes? :)

  Are you sure? yes | no

Just4Fun wrote 02/03/2017 at 14:47 point

Hi all, the C toolchain seems to work. I'm using SDCC (I'm pretty new to SDCC, and i had to figure how to do...).

Here is an ANSI test taken from here: (and only a little adapted...):


Stay tuned...

  Are you sure? yes | no

john wrote 02/03/2017 at 15:32 point

Too cool!  Very nice work with the loader!

  Are you sure? yes | no

WestfW wrote 01/30/2017 at 08:53 point

Hmm.  it occurs to me that for old CPUs that have DMA based on "I release the bus!" mechanisms, you could essentially simplify the interface even further (though probably not get the chip count any lower.)  A "mailbox" of shared memory, plus "ATTN", BUSREQ, BUSACK, and RESET, and that's it.  The Z80 (or whatever) would put stuff at a known location and signal ATTN to the AVR, which would then take the bus, read and re-write the shared memory, and give it back.  At poweron, the AVR could put the bootstrap in low memory instead.
I guess the problem is that while you'd still be running on an actual Z80, it would rapidly become non-retro-like WRT its IO...

  Are you sure? yes | no

Just4Fun wrote 01/31/2017 at 07:21 point

Interesting approach... virtually HW independent...

A problem in this case would be that the various CMOS SRAM seem to have strictly TTL outputs (at least datasheets says so...), so readings SRAM directly from an AVR would be possible only using an analog read for each pin and reassembling the byte... possible (in fact the data bus pins are also analog pins... it is not a coincidence...) but time consuming... so I left this way as last chance.

  Are you sure? yes | no

WestfW wrote 01/31/2017 at 09:40 point

Hmm.  The RAM Voh specs are a little annoying, aren't they?  Since the technology is CMOS, I *suspect* the low guaranteed output voltage is a current drive issue, and won't come into play as long a everything that's connected is also CMOS (and not requiring any drive current to speak up.)  In any case, since I'm still waiting for my Z80s, I've been playing with just the AVR and memory, including writing a little "memory test" utility that writes AND READS the memory from the AVR.  It seems to work fine (even though my memory chip also says 2.4v min output.  And the scope shows a nice and solid 5V output.  (you spend a lot of time poking around with a scope if you forget that you have to read PINx rather than PORTx.  Sigh.  The test program pretty much lets you step through individual accesses so you CAN poke around, as well as doing the full speed memory test.)

Single Step Memory Read from 7
Requesting DMA. DDR = 00 f3 fc fc.  PORT = 8a 72 1a 21
Control signal. DDR = 00 f3 fc fc.  PORT = 8a 72 1a a1
Bus Direction. DDR = 00 f3 fc fc.  PORT = 8a 72 1e 21
MREQ_ low   . DDR = 00 f3 fc fc.  PORT = 8a 32 1e 23
RD_ low     . DDR = 00 f3 fc fc.  PORT = f8 12 1e a3
RD_ high    . DDR = 00 f3 fc fc.  PORT = f8 32 1e 23
MREQ_ high  . DDR = 00 f3 fc fc.  PORT = f8 72 1e a3
Data read: f8 if you'd like to play with it.  I *think* it should work with or without the Z80 in-circuit...

  Are you sure? yes | no

Just4Fun wrote 01/31/2017 at 10:16 point

Ops... I've realized only now "Who" you are... :-)

  Are you sure? yes | no

K.C. Lee wrote 01/31/2017 at 10:40 point

I suspect the TTL compatible VOH (min) is left over from the old days for old TTL loads.  Chances are that it would go to full rail for CMOS high impedance only loads.

CMOS input threshold is actually targeted to be half rail.  All the AC timings are usually specified that way. However this parameter is dependent on the input MOSFET P and N types to be identical.  They also want to have enough guard band to make sure that the input stage doesn't have shoot through.

Unfortunately can't depend on the being full CMOS compatible for a proper paper design even though it would likely work for most parts not under extreme conditions.

  Are you sure? yes | no

WestfW wrote 02/01/2017 at 00:48 point

Hmm.  Even the CMOS Z84C00xxx chips have the same 2.4V Voh spec.  Perhaps we're just lucky.  I never would have noticed; is there some famous example of CMOS SRAM *not* working with modern CMOS processors?

  Are you sure? yes | no

Just4Fun wrote 02/01/2017 at 05:27 point

In the Z80 CMOS datasheet there is the Voh2 parameter valid if load is not greater than 250uA. In this case Voh2 is higher than 2.4V...

See page 30 (of the file) here:

Instead in the various CMOS SRAM datasheet nothing is said for "low" load... :-(

  Are you sure? yes | no

K.C. Lee wrote 02/01/2017 at 10:08 point

You can find them if you know what to look for (and what to do with it).  

There are IBIS model for simulation which are essentially voltage vs current curves data for I/O pads.  These are what people typically use for signal integrity simulation.  under Software & Tools

  Are you sure? yes | no

K.C. Lee wrote 02/01/2017 at 10:24 point

FYI: The typical VIH is actually very similar to TTL at 5V.  It is however not part of the guaranteed specs.

  Are you sure? yes | no

Just4Fun wrote 02/02/2017 at 07:43 point

Interesting... I have not ever thought about using those simulation models...

  Are you sure? yes | no

Just4Fun wrote 01/28/2017 at 19:37 point

Hi all, a new update is coming... Stay tuned...


  Are you sure? yes | no

Similar Projects

Does this project spark your interest?

Become a member to follow this project and never miss any updates