Close

Jupyter Notebook - 3 days to get a Photo of a Cat

A project log for WEEDINATOR 2019

The WEEDINATOR project continues .... The inevitability of robots working on farms draws ever nearer ....

Tegwyn☠TwmffatTegwyn☠Twmffat 09/21/2018 at 11:160 Comments

I think my pain threshold for using Ubuntu has now substantially increased as I can now install packages and their dependencies in some sort of tenuous quasi logical way. I made some notes of how and what I had to do below, which will make absolutely no sense to anyone unless they are trying to use Jupyter notebook. It seems that installing DIgits created an unsuitable environment for Jupyter and in retropect, it might even have been better to skip Digits and go straight to Jupiter:

AttributeError: 'Cycler' object has no attribute 'change_key'

sudo pip3 install --upgrade cycler
 
                        * The following required packages can not be built:
                            * freetype, png
                            * Try installing freetype with `apt-get install
                            * libfreetype6-dev` and pkg-config with `apt-get
                            * install pkg-config`
                            * Try installing png with `apt-get install
                            * libpng12-dev` and pkg-config with `apt-get install
                            * pkg-config`

sudo apt-get install libfreetype6-dev
sudo apt-get install pkg-config
sudo apt-get install libpng12-dev
sudo apt-get install pkg-config
pip3 install -U matplotlib --user

 Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
    Beginning with Matplotlib 3.0, Python 3.5 and above is required.
    
    This may be due to an out of date pip.
    
    Make sure you have pip >= 9.0.1.
    
digits 6.1.1 has requirement matplotlib<=1.5.2,>=1.3.1, but you'll have matplotlib 2.2.3 which is incompatible.
digits 6.1.1 has requirement protobuf<=3.2.0,>=2.5.0, but you'll have protobuf 3.6.1 which is incompatible.
 
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-CoCAUs/matplotlib/
You are using pip version 8.1.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

jupyter notebook
ipython notebook

caffe_root = '/home/nvidia/caffe/'
pip install pyyaml

export PATH=$PATH:/home/nvidia/.local/bin

pip install jupyter --user
pip3 install jupyter --user

pip install -U matplotlib
pip3 install -U matplotlib

AttributeError: 'module' object has no attribute 'to_rgba'

Matplotlib requires the following dependencies:

Python (>= 3.5)
FreeType (>= 2.3)
libpng (>= 1.2)
NumPy (>= 1.10.0)
setuptools
cycler (>= 0.10.0)
dateutil (>= 2.1)
kiwisolver (>= 1.0.0)
pyparsing

sudo apt-get install python3-matplotlib

Matplotlib to_rgba jupyter notebook AttributeError: 'module' object has no attribute 'to_rgba'

python -mpip install -U pip
python -mpip install -U matplotlib
pip install --upgrade pip

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/bin/jupyter-run'
sudo chown -R $USER /usr/local/lib/python2.7
sudo chown -R $USER /usr/local/bin/jupyter-run

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/bin/jupyter-run'
Consider using the `--user` option or check the permissions.
pip install jupyter --user

  The scripts jupyter-bundlerextension, jupyter-nbextension, jupyter-notebook and jupyter-serverextension are installed in '/home/nvidia/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  The script jupyter-console is installed in '/home/nvidia/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.

Discussions