Close

Serial problem with the new board

A project log for Tact-Tiles

A low-cost open-source scalable hardware platform for the development of interactive systems for deafblind people

Anderson AntunesAnderson Antunes 09/16/2015 at 10:230 Comments

My test on the Bluetooth module did not work, It can send messages to my cellphone but it always receive “0” when I try to reply them (displayed as a blank line after the letter in the image below).

Oddly I found that every time that I sent a “y” it returned a “@”, this made me realize that it might be a software problem, but when I tried the same code in my Arduino Mega 2560 it worked... So I still don't know what it is all about, but I have some guesses:

I also tried to make a serial connection between my Arduino Mega and the board and got the same results.

I think this is a problem with this unity only, so tomorrow I will assemble another board and see if this is really the case.

If someone has an idea about what can it be, please share! ;)

UPDATE: I assembled a second board and got the same results, I also tried making a connection with my Arduino Mega again and it worked! So probably the problem is in Bluetooth module, but is still odd that it works perfectly with my Arduino Mega. Anyway, I bought another Bluetooth module, and I will resume my tests in the weekend.

Discussions