Relief and Revelations!

A project log for ESP32 LoRa Gateway

ESP32 with dual LoRa modules

morganmorgan 12/04/2021 at 04:0511 Comments

Few things are worse than bugs that just don't make sense. I went over and over my schematic, I went over the CP2102N Errata, I went over my soldering and simply nothing was wrong. And after building up my second board (and most of a third) to get the same issue I was getting really frustrated.

One thing I hadn't tried was..... another computer. So the phantom USB issue I've been battling for weeks was actually an issue with my desktop. Fuuuuuuuuun.

The good news here is that I'm now not in a rush for a second revision. The only major changed planned was breaking out the few remaining pins. So as is, these will be acceptable for being deployed as relay nodes but until another revision is done additional sensors won't be possible. This is great!

The last remaining test I have is the battery charge circuit. Though I'm not sure if this will get used as I'm likely going to power these early nodes from an OrangePi Zero USB port that will be powered from LiFePO4 batteries charged by a #LiFePO4wered/Solar1 module.

Look at that! Three of them and they all work! Hopefully the next update will be these, in enclosures with antennas and everything! woot!


Helen wrote 12/28/2021 at 19:56 point

I'd love to, but at 6-12 Mb/s download and 3 in upload depending on weather. Mts. Noire, S W France! Beautiful calm.... laughable internet. Love it here!

  Are you sure? yes | no

Simon Merrett wrote 12/06/2021 at 11:46 point

Hooray, glad you got this working better! 

  Are you sure? yes | no

morgan wrote 12/08/2021 at 19:24 point

Yyyyeah, it's still not ideal and I've identified another problem. The lack of pull-down resistors on the LoRa reset line is causing SPI and driver init issues. I cannot think of a solid reason this would contribute to the boot issue though.

  Are you sure? yes | no

Simon Merrett wrote 12/09/2021 at 14:15 point

Could it be that IO12 isn't reliably pulled low during ESP32 boot? Sorry if that's what you are saying already. 

  Are you sure? yes | no

morgan wrote 12/09/2021 at 18:05 point

I was not suggesting that, but it was also on my mind as the only (albeit unlikely) thing I can think of. This would mean the SX1276 fires off random interrupts on boot, which feel unlikely. I'm going to test this theory this afternoon on a different board.

  Are you sure? yes | no

morgan wrote 12/11/2021 at 04:39 point

Bah! I popped a 1k pull-down resistor on IO12 but the USB still isn't resetting. Really at a loss to what's going on.

  Are you sure? yes | no

Simon Merrett wrote 12/11/2021 at 08:57 point

Any use for a comparison and confirmation of the signal logic needed?

  Are you sure? yes | no

morgan wrote 12/11/2021 at 17:19 point

oh! OOOooooh! I'm using N-Channel MOSFETs when the design calls for using NPN Transistors.

  Are you sure? yes | no

morgan wrote 12/11/2021 at 20:28 point
Turns out the strapping pins have internal pull resistors. IO12 is pulled up, IO0 is pulled down.

  Are you sure? yes | no

Simon Merrett wrote 12/13/2021 at 07:29 point

Does this mean rev 2 is a higher priority than anticipated? Or can you fix the boards you have? 

  Are you sure? yes | no

morgan wrote 12/14/2021 at 01:11 point

I just don't even know at this point. I replaced the MOSFETs with NPN transistors and it still behaves the same. And with some suggestions from @Patrick Van Oosterwijck (thanks) I dug a bit further to test wether the ESP32 is booting after the flash... and it is. This solidly puts the blame on the CP2102N as I suspect.

  Are you sure? yes | no