• Progress!

    morgan2 days ago 0 comments

    Last I left off, I was trying every incantation of tcpdump I could muster with little success. It was obvious the projector was self assigning an address and simply not broadcasting *anything* to the network. I tried some broad range ping sweeps but between fighting routing tables and the likelihood an embedded device like this would ignore pings (it didn't) I didn't put a lot of effort into this. Instead I sank to the last resort of any hacker worth their weight in flux and I... contacted the manufacturer.

    And it worked! A couple of nice folks at Visitech got back to me with some basic questions and gave me a dropbox full of documents!

    As suspected the device self assigns an address on reset,, how'd my  ping sweet not hit that?!? I blame the routing tables.

    Status screen for Luxbeam 4600
    We're IN!

    Before talking about this interface, I did some other poking around while I was attempting to get this webpage (routing taaaables!) and found interesting things. It has telnet and ssh servers but not only do the web interface credentials not but the ssh is public key only.

    Presumably the FTP is to upload images and sequences, ls shows nothing and I  haven't seen anything in the documentation yet, and frankly, don't care that much right now. And in general, this is about as far as I'm going in this direction, but the fact there's an FGPA running Linux in there ight make  for some compelling hacking in the future.

    So at this point I have access to the web ui, documentation for the UDP protocol and have successfully loaded an image and tested the optics.

    Grid of test dots
    Test Pattern, 1920x1080 pixels across ~42mm

    This is one of the preloaded test patterns ''faaaaiiirly in focus". It's hard to take a picture while holding a piece of paper in focus. It also shows the current projection size is about 42x25mm (1.5 x 1" maybe?) for a 1920x1080 pixel image.

    UV Jolly Wrencher projected on white paper
    My test pattern

    At this point, I'm basically happy with the control aspects. I can load a custom image, I can turn the LED on/off, in theory scripted. The next part in a bit daunting.

    Morgan Becomes an Optimist!

    Errrr, optometrist! Errrr, obstinatist? Optication! YYeah, why let a bad joke go?

    This  part is going to be hard. Not only do I know basically nothing about optics, I suspect it will involve a lot of finicky adapter parts, stuff I usually don't have a lot of patients for. The goal is to increase the projection size to cover most, if not an entire 'standard' 4x6'" copper clad board. But in the short term, I'm going to build a platform at the current ~60mm focal distance and do some test exposures for tiny boards. This will give me some time to troll craigslist for 'optics' (broken camera lenses) to experiment with. And lastly, I really liked this picture of the LCD with the light source off.

  • Yup, I sure have one.

    morgan04/10/2020 at 04:16 0 comments

    So the auction closed and I ended up getting the complete unit for $US50. I have been unable to determine what a unit like this went for new, but I can image it being much, much higher than this.

    Hardware Rundown

    This lot (there were 4 total) came with, PSU, the main projector unit and an optical stage. I'm unsure what the optics are setup for (shrink, enlarge) but one of the other lots included a frame, with an acrylic bed about 10cm above the lens.

    Unit Body

    The main body includes several ports, PSU, two optical sync (IN/OUT), and electrical sync, 6 GPIO pins, Ethernet, a reset button and ethernet reset button. PSU was helpfully labeled and allowed me to confirm the include supply was correct and wired correctly. With that I was able to power it up to find the fan grill hit the blades and made a horrendous noise. But with that fixed, I was able to see if I could get it on the network.


    The best info I can find for this is the 'datasheet' for a similar (might be the same?) model called the LE4960H DIS. The DIS part of this indicates the projection optics and the controller are separate, presumably allowing the optics to be mounted in more confined places. The H part is still an unknown. The important part though is the fact this datasheet says the control is web based, and the host controller simply needs a browser. And hey, I've got one of those.

    The Problem

    So this browser based control seems really handy, problem is, so far nothing I've tried will get this thing on my network. I doesn't seem to ask for an IP, isolating it on a switch with my desktop I cannot see anything going out with tcpdump but the ethernet LEDs on the device are lighting like they're trying to do something. I also tried hooking it directly to my desktop but only one LED lit up, I'm guessing this is a patch/cross over cable thing issue? Or maybe something with 1000Base-T ethernet that I don't understand?

    Any suggestions would be handy, this is pretty much where I'm at.